Chameleon

Issue 146: Boot error without VESA mode defined in Boot.plist

Reported by Scott M, Aug 16, 2011

The bug is as follows:

After boot menu, if booting without flags – instant reboot

After boot menu, if booting with -v boot flag it brings you to a 
black screen, with a white bar on top that flickers, but that is as 
far as it goes.

After boot menu, if booting with -f or -x boot flags it will boot.

While the exact cause of this isn’t yet clear to me I have narrowed 
it down considerably by downloading, compiling and testing many many 
revisions of the chameleon trunk starting with the one I knew worked 
(2.0 RC5 revision 1203) my results were as follows:

    1221 = broken (bug I mentioned above is reproduced, all future 
revisions including 2.0 final – r1394 – share this bug)
    1220 = can’t boot (other bug)
    1219 = can’t boot (other bug)
    1217 = can’t boot (other bug)
    1216 = build failed
    1214 = build failed
    1203 = works

If you add a VESA graphics mode to your boot plist on revisions 
higher than 1203 it will boot normally. In revision 1203 defining 
VESA graphics in Boot.plist isn’t needed.

The card I was testing with is a 9800GTX+. But other users have 
reported it with other graphics cards.

Comment 1 by Scott M, Aug 16, 2011

I was using meklort's buildbot as a reference for the builds, he 
said the build failed only because he was messing with buildbot, so 
I will grab the others from SVN and compile again.

Note: I didn't use any precompiled binaries from buildbot I was just 
referencing the waterfall view.

Comment 2 by Scott M, Aug 16, 2011

Tested 1214 and 1216 - both have the same problem as 1217-1220 - 
can't boot due to other bug introduced by mozodojo in 1214 and fixed 
by meklort with a reversion in 1221.

So the most I can narrow it down is at some point between 1203 and 
1221.

Comment 3 by Scott M, Aug 16, 2011

Ok so meklort told me what was causing builds 1214-1220 to not boot.

line 630 in boot.c 

strcpy(bootFileSpec, bootFile);

so I replaced that with:

strcpy(bootFileSpec, bootInfo->bootFile);

And tested them. Got it narrowed down to a single commit now.

1220 = broken (white bar)
1219 = works
1217 = works
1214 = works

Comment 4 by Scott M, Aug 16, 2011

So... based on 
http://forge.voodooprojects.org/p/chameleon/source/commit/1220/

I reverted those changes to drivers.c on build 1394. And the system 
now boots normally without a VESA graphics mode defined in the 
Boot.plist.

Comment 5 by Evan Lojewski, Aug 16, 2011

Should be fixed in revision 1406

Comment 6 by Evan Lojewski, Aug 16, 2011

Status: Fixed

Comment 7 by Scott M, Aug 16, 2011

Not fixed. Revision 1406 has same problems as 1220-1405 even though 
the code was changed.

Comment 8 by Scott M, Aug 16, 2011

1407 boots as would be expected with -v boot flag, without flags 
however there is a minor problem still. The apple logo will appear 
in top left corner of screen, the rest of the screen is blank 
(black) and no spinner is visible. If patient though it will boot 
still.

Comment 9 by lllevelll lllevelll, Sep 2, 2011

Confirm, 1485 --> Apple logo still appears 
in top left corner of screen, the rest of the screen is blank 
(black) and no spinner is visible.
It will boot however. WTF?

Comment 10 by lllevelll lllevelll, Sep 2, 2011

With empty Graphics Mode ("Graphics Mode"="" 
@boot prompt or in a *Boot.plist).

Comment 11 by JrCs, Dec 14, 2011

Is the issue still valid ?
Status: AwaitingInformation

Comment 12 by Scott M, Feb 23, 2012

The original issue is resolved, but the issue with apple logo in top 
left corner of screen & rest of screen blank is still a problem 
with r1827. It seems to only happen on some graphics cards - I only 
see it on my system running an HD6870. It is purely a cosmetic issue 
though, boot process continues normally since r1407+.

Comment 13 by Cosmosis Jones, May 5, 2012

Status: Invalid

Created: 7 years 10 months ago by Scott M

Updated: 7 years 1 month ago

Status: Invalid

Followed by: 4 persons

Labels:
Priority:Medium
Type:Defect

This issue is related to
171 - App...with empty Graphics Mode