Chameleon

Issue 156: GE allocation error, when using Bullet theme

Reported by Cyrus The Great, Aug 22, 2011

Steps to reproduce the problem:
1.add GraphicsEnabler flags 
2.reboot
3.get error that attached to post

Expected result:inject my card

Actual result:its stock on this error

Comment 1 by Cyrus The Great, Aug 22, 2011

when add ati rom to extra folder its work.i think the problem is 
reading vbios from legacy space

Comment 2 by Cosmosis Jones, Aug 23, 2011

Please post ioreg and bdmesg dumps as well

please post your hadware
(dev id && subsys id)
Owner: azimutz

Comment 3 by Cyrus The Great, Aug 23, 2011

hi this my ioreg with ati rom in extra folder
my card is ati mobility radeon hd4650 
10029480&3228103C
thanks

Comment 4 by Cyrus The Great, Aug 23, 2011

sorry forgot bdmesg

Comment 5 by Azimutz, Aug 24, 2011

Hi Akbar.. if i do remember, the trunk was working fine for you!? 
What changed?... i'm suspecting about XCode4...
What version is used on the booter you're using?

This has nothing to do with "loading" the VBIOS; maybe it 
has to do with "reading" it? This error comes from 
get_romrevision_val; what's interesting is that's the first time i 
see this function actually retrieve a "decent" romrevision 
value (ATY,Card#: 42 52 34 30 34 34 33 2e 30 30 31 = BR40443.001).. 
it looks like loading a rom file makes it work properly!?
Anyway, i don't get this allocation error, but can't load a rom file 
(one more to debug); this is with what i managed to merge from the 
old code into the new GE; ii can't use the trunks GE!!
Check the XCode thing; try using a build with XCode3, if you're not 
doing it already...

Comment 6 by Cyrus The Great, Aug 24, 2011

hi azimutz.
yap i build it with xcode4.1 also add hibernate patch that a guy 
post in issue section(the hibernate now work in lion)i will try with 
other xcode verion from build bot and report back.
and other thing when i am get my video rom using everest its 61 kb i 
put it in extra folder and GE work without problem.but i read the hp 
manual and its say my video bios rom address (
128 KB 000A0000-000BFFFF Video memory
48 KB 000C0000-000CBFFF Video BIOS)
i read it using RW-everthing and the save the file(48 kb)
when i replace the 61 kb with 48 kb video rom .
agian the error that i posted came back

Comment 7 by Cosmosis Jones, Aug 24, 2011

Azimutz what GE are you referring to when not on the trunk?
Which one works for you, i'm very confused by this

Comment 8 by Azimutz, Aug 24, 2011

Cosmo, to put it simple; old code ( < r786) works with my legacy 
card (RV516), the new  doesn't; it has none of the old support for 
legacy cards. That's the main reason why i keep the 
trunkGraphicsEnablerModules folder on my branch. On a day to day 
basis i use the module with the old code, but i'm also trying to 
merge the old with the new; it's to this last one that was mainly 
referring to; it's the closest i have to the new code, but it's not 
committed yet. More info on the topic ;)
http://forum.voodooprojects.org/index.php/topic,1959.0.html

Akbar, the XCode 3.2 build is disabled on the bot; use the attached 
one if you need.

Comment 9 by Cyrus The Great, Aug 24, 2011

azimutz;
i am test the package that you posted with xcode 3.2
its get me same error as before.i will test later the older package 
in buildbot to find the revision that error come with it.

Comment 10 by Azimutz, Aug 25, 2011

Well, i guess we can exclude XCode, i'm using 3.2.6.
Try the package attached; i reverted the last ati.c changes i made 
on it. Makes no sense, but i have a faint idea of getting one of 
those allocation errors while trying to add some verbose...

Comment 11 by Azimutz, Aug 25, 2011

Package :P

Comment 12 by Cyrus The Great, Aug 25, 2011

i test it without the videorom gets the same error as before

Comment 13 by Azimutz, Aug 26, 2011

As far i can see and remember, there was no change on the GE code to 
cause this and my usual suspects are excluded...
Any one else having this?

Comment 14 by Cyrus The Great, Aug 26, 2011

its seems that problem with rom size. GE accept the a range of 
size.its accept 62 kb and get error with 48 kb .

Comment 15 by Azimutz, Aug 26, 2011

There's no limit for rom size; there used to be on the old code, but 
it was a max limit. Rom's all show 66KB on my system; your's dumped 
from the ioreg 66 KB on disk (63,488 bytes).
I saw you updated the rom; can that be the problem??

Comment 16 by Cyrus The Great, Aug 26, 2011

yes
i am update my bios to latest version it update my videorom
by i revert back it again to previous bios .for power menu.
the other thing that i can mentioned .the video rom of some mobile 
card is locked and can not be reader by any soft(everst read it from 
shadow space)i extract one from the main bios update file .and 
chameleon work with it 61 kb.
also its work with one that i extract with everest.
my be bios reading problem!!

Comment 17 by Cyrus The Great, Aug 26, 2011

i found the problem
it is with bollet theme .i change the theme to defualt and GE work 
with or without Video rom in extra folder.

Comment 18 by Azimutz, Aug 28, 2011

Yep, i can reproduce this, but NOT with my "closest to the 
trunk" stuff..??.. and i can't see the connection..???
As far as i can see, there's nothing wrong with the theme.

Comment 19 by Cyrus The Great, Aug 28, 2011

may be the problem is with size of boot logo .any way i test legacy 
theme and other one the only case that error occurred is bullet.

Comment 20 by Azimutz, Aug 28, 2011

Boot logo is not loaded at the time of the error; it's one of the 
last things to be loaded before passing control to the kernel and 
only if booting without -v.
Let's give some time to this.
I will accept the issue and change the summary accordingly.
Summary: GE allocation error, when using Bullet theme

Comment 21 by Azimutz, Aug 28, 2011

Status: Accepted

Comment 22 by Cosmosis Jones, May 8, 2012

Status: WontFix

Created: 7 years 10 months ago by Cyrus The Great

Updated: 7 years 2 months ago

Status: WontFix

Owner: Azimutz

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect