Chameleon

Issue 169: Raid 0 doesn't boot with build 1494

Reported by Luis Galhardo, Sep 2, 2011

I've just updated to build 1494 and my Raid 0 doesn't boot anymore. 
It hangs on: devfs_kernel_mount: f

Anyone with same problem with this build and raid 0 ?

Comment 1 by mozo, Sep 2, 2011

I have the same problem with latest rev. Kernel hangs on: dev'

Comment 2 by BriLoh, Sep 3, 2011

I have added all the kexts from /E/E/ to S/L/E and rebuilt the 
cache. Hangs at "Waiting for DSMOS"  Now, there is just no 
way into this thing.  Everything yields the same result.  
"UseKernelCache", normal booting, -x, -v, mixed 
combinations.  Nothing.

Comment 3 by Cosmosis Jones, Sep 3, 2011

Is it from the boot-uuid i added back?
Status: Accepted
Owner: jrcs

Comment 4 by mozo, Sep 3, 2011

It's from FaceTime fix

Comment 5 by Cosmosis Jones, Sep 3, 2011

yes i get that. The boot-uuid from the selected partition isn't 
correct for raid. We are probably just going to shove this into a 
module or figure out a global boot-uuid that is set from 
boot/options.c.

and publish that to the efi tree

Comment 6 by JrCs, Sep 4, 2011

I have revert the patch waiting to find a valid fix that don't break 
the Raid

Comment 7 by mozo, Sep 4, 2011

SoftRAID root UUID is on the helper partition in folowing folder: 

/com.apple.boot.[P/R/S]/Library/Preferences/SystemConfiguration/com.a
pple.Boot.plist

:)

Seems we should use volume UUID not the system UUID.

Comment 8 by mozo, Oct 18, 2011

This is chameleon rev1618 (latest trunk) with iCloud & FaceTime 
fix working with Soft RAID 0

Comment 9 by Cosmosis Jones, Oct 18, 2011

did u take into account the icloud device limit issue?

Comment 10 by mozo, Oct 18, 2011

I have no idea about this issue... The problem here was improper 
UUID written to /chosen/boot-uuid. Should be virtual RAID volume 
uuid, not the helper partition one.

Comment 11 by Cosmosis Jones, Oct 18, 2011

yeah there's an issue of the way the boot-uuid is getting gerneated 
in other scenarios where chameleon is generating new ones w/ the 
base oleg patch.. which means after 3 boots you are out of icloud 
devices..

But the part about the raid will be helpful. I know jrcs had a patch 
he had finished yesterday and was going to test.. 
Thanks this will still remain open until jrcs takes a peak.


Did u attach a diff file?

Comment 12 by Mark S, Oct 18, 2011

mozo, the 1618 works with RAID, confirmed.  As Cosmosis mentioned my 
iCloud is throwing the invalid account error.

Comment 13 by mozo, Oct 18, 2011

Code review ^, check it ;)

or http://forge.voodooprojects.org/p/chameleon/review/6/

Comment 14 by JrCs, Oct 19, 2011

I think i will release the patch this week-end.

Comment 15 by Mark S, Oct 21, 2011

Hi,
I used EFI Studio 1.1 to generate a EFI String for my Ethernet 
Device.  Put that in the org.chameleon.Boot.plist and now my en0 is 
showing up with BuiltIn true.
If you run:
ioreg -lS -w0 | grep -A11 en0 |egrep "BSD Name|IOBuiltin"
and its "No" that might be a quick place to check to see 
why iCloud and or App Store sign on is failing.

With the build Mozo supplied Oct 18th rev 1618, I'm up on RAID and 
with the EFI patch I'm up on iCloud.

Comment 16 by JrCs, Oct 22, 2011

Fixed in r1469
Status: Fixed

Comment 17 by JrCs, Oct 22, 2011

Sorry the fix is in r1649

Comment 18 by Diederik van den Burger, Oct 22, 2011

I upgraded to r1649, but still no iCloud for me...
Using a soft raid 0 setup.

Comment 19 by JrCs, Oct 22, 2011

@Diederik van den Burger please double check because it's working on 
all soft raid 0 where i test the fix.
Are you in version 10.7.2 ?
What do you have in the /chosen devicetree ?

Comment 20 by Cosmosis Jones, Oct 22, 2011

Also make sure your have ethernet built-in yes, and en0

Comment 21 by Diederik van den Burger, Oct 22, 2011

Yes, I am running 10.7.2 and I have ethernet build-in yes set in my 
plist, but still no iCloud.
I installed the bootloader several times, but still no succes.

The weird thing is that I got two KP's, but the third time I was 
able to boot.

What do you mean precisely by what I have in my chosen devicetree?

Oh and btw: I used the Hackinstaller script to install the 
bootloader, 'cause I'm not very sure how to compile / install it 
manually on a raid setup.

(http://www.insanelymac.com/forum/index.php?showtopic=185097) -> 
Hackinstaller script.

Comment 22 by JrCs, Oct 22, 2011

Can you attach the bdmesg log ?

Comment 23 by Diederik van den Burger, Oct 22, 2011

Here you go.
Could the problem be that I have a motherboard with 4 built-in 
ethernet ports?

Comment 24 by Diederik van den Burger, Oct 22, 2011

So I booted to my BIOS, disabled the other LAN ports, and now 
everything's up and running.
Problem is that I require at least one other LAN port to work. Is 
there a solution to this problem?

Thanks for helping by the way ;)!

Comment 25 by Cosmosis Jones, Oct 22, 2011

This isnt' the place for that discussion, but yes you can fix it 
you'll have to do either a dsdt edit or abuild an efi-string 
(deviceproperties) for the ethernet ports u need/want.

Comment 26 by Paris Holley, Oct 30, 2011

I cannot get icloud to work on raid 1 setup, i have en0 and builtin 
working through dsdt, app store works, but icloud gives me 
"unrecognized apple id or password"..i have generated a 
new smbios with a unique serial, but no go

Comment 27 by Cosmosis Jones, Oct 30, 2011

Please dont' comment on fixed tickets. Post your question in the 
forums.

Do u have a valid SMBoardProduct in your smbios?

Created: 3 years 1 month ago by Luis Galhardo

Updated: 3 years 1 day ago

Status: Fixed

Owner: JrCs

Followed by: 6 persons

Labels:
Priority:Medium
Type:Defect