Chameleon

Issue 285: OS X 10.8.2 kernel: only with -v verbose boot - without KP

Reported by Andreas Michalak, Aug 26, 2012

I used 10.8.0, 10.8.1 on my C2D Hackintosh.
After updating to 10.8.2 it only boots with -v verbose flag?!
Without verbose it KPs very early in the boot process.
Must be before any kernelcache or .kext getting used/init.
Only the cpu registers are displayed on the KP screen.
Normally i know. if KP later the last .kext (gpu, lan, cpu 
powermanagement) is shown as kp reason.

I dont know in detail what makes the diff for kernel / chameleon if 
-v is used compared non -v booting. Must be something in deep / 
detail.

Comment 1 by Evan Lojewski, Aug 26, 2012

Try booting with just the kernelflag keepsyms=y and without -v. If 
that still kernel panics, take a picture and upload it.

If it doesn't kernel panic, boot normally and post a picture, 
additionally, we'll need to know what kernel you are using to boot 
with.

Comment 2 by Andreas Michalak, Aug 26, 2012

I will do that.
Since which chameleon/chimera version keepsyms=y is supported. I use 
chameleon 2035 + chimera 1.11.1 (lastest) with same -v works symptom.

Comment 3 by Andreas Michalak, Aug 26, 2012

Sorry, if its an kernel flag chameleon version doesnt matter after 
thinking about that;)

Comment 4 by Andreas Michalak, Aug 26, 2012

GREAT !!
keepsyms=y without -v helps to avoid KP

as info some of the bdmesg log:
Chimera 1.11.1 (svn-r1394) [2012-08-08 21:15:51]
MSR_IA32_PERF_STATUS: 0x06000a20
max: 10 current: 10
CPU: Brand String:                Intel(R) Core(TM)2 Duo CPU     
E7300  @ 2.66GHz
...
Customizing SystemID with : 00000000-0000-0000-0000-001d7dd11bf3
Read HFS+ file: [hd(0,1)/Extra/DSDT.aml] 11840 bytes.
ACPI table not found: SSDT.aml
FADT: Restart Fix applied!
FADT: Using custom DSDT!
Found ACPI CPU: CPU0
Found ACPI CPU: CPU1
Found ACPI CPU: CPU2
Found ACPI CPU: CPU3
SSDT with CPU C-States generated successfully
SSDT with CPU P-States generated successfully
RSDT: Added 2 SSDT table(s)
Starting Darwin x86_64
Boot Args: boot-uuid=E77BB132-241B-37E0-99B9-4B6CBE286A69 rd=*uuid 
keepsyms=y

Comment 5 by Evan Lojewski, Aug 26, 2012

keepsyms=y is supported in pretty much every version in xnu. It's 
certainly supported in any 10.4+ version

It's not a workaround for the panic, it's meant to print out more 
useful debugging information when it does panic.

Would you please post the panic that you do get with no kernel flags 
as well as the kernel version you are using.

Comment 6 by Andreas Michalak, Aug 26, 2012

Ok, i will try that. First boot (after keepsyms=y worked) without 
any flags run well. Never worked like this (100% same KP tested 
>10 times). My hardware also stable + valide. 
Can that once keepsyms=y made some thinghs happed which later it 
isnt needed anymore?
Will try more reboots without any flag to get that KP back.
PS: Since long time (Lion) i boot always with usekernelcache=y. I 
can also switch that off for test if you want.

Comment 7 by Evan Lojewski, Aug 26, 2012

I just want a copy of the kernel panic so that we can trace down the 
actual cause of it.

Comment 8 by Andreas Michalak, Aug 27, 2012

I now get serveral KPs again, doesnt matter keepsyms or not. Only -v 
never had KPs last 20 boots.

Comment 9 by Cosmosis Jones, Aug 27, 2012

god thats a horrible picture.

Comment 10 by unix service, Aug 30, 2012

Hi i found this bootflag for chameleon documentation:


io=0xffffffff -v

booting 10.8.2
Registering: IOService:/
waitForSystemMapper
Backtrace
Kernel Extensions in backtrace:
com.apple.driverAppleACPIPlatform (1.6)
dependency: com.apple.iokit.IOACPIFamily (1.4)
dependency: com.apple.iokit.IOPCIFamily (2.7.1)


IOPCIFamily (2.7.1) «« is new. im probed copy rollback to 2.7 same 
fail.

Enoch bootloader (rev 2035-2050) 12.2.0 kernel not recognize ACPI 
state (any other bootlader same)

Comment 11 by unix service, Aug 31, 2012

im rollback three kext AppleACPIPlatform
IOPCIFamily and IOUSBFamily.

recognized normaly ACPI state and booting normal for 10.8.2 beta

Comment 12 by Andreas Michalak, Aug 31, 2012

Your problems seem to be different than mine.
Because in your case i think using -v (verbose) will also KP because 
of that kext problems.
But my problem, very early KP, before any kext is used, if i dont 
use -v is different.
Between last days i never got KP with -v, but several times (not 
every time without -v) this early boot KP if i dont use -v.
Something, like timing or branches with and without -v must be 
different.
I updated today to new 10.8.2 C35 (before C31) and will try booting 
without -v again to test if the prob is gone.
PS: I can use the vanilla IOPCI, IOACPI kexts without any KP on my 
C2D , Intel G35 Chipset.

Comment 13 by unix service, Aug 31, 2012

Andreas please check ACPI state ( booting -v)

Comment 14 by Andreas Michalak, Aug 31, 2012

I made an new much better(sharper) foto about KP without -v. Now 
with 10.8.2 C35.
Used keepsyms=y. KP looks same as my (bad quality)first foto.

ACPI:
Aug 31 12:11:18 localhost kernel[0]: IOAPIC: Version 0x20 Vectors 
64:87
Aug 31 12:11:18 localhost kernel[0]: ACPI: System State [S0 S3 S4 
S5]

compared to an older (10.8.0/10.8.1) syslog:
IOAPIC: Version 0x20 Vectors 64:87
Aug 16 17:38:07 localhost kernel[0]: ACPI: System State [S0 S3 S4 
S5] (S3)

Difference is that with older OS X (10.8.0 / 1) (S3) is listed at 
the end.

Comment 15 by unix service, Aug 31, 2012

this workaround is work:

install rollback /S/L/E

Comment 16 by Andreas Michalak, Aug 31, 2012

Seems that IOPCI Set helped avoid KP in 10.8.2.
 NO more KP, doesnt matter with or without -v.
System State [S0 S3 S4 S5] (S3), (S3) came back.
The before logged PCI configuration begin and end logs disappered.

Comment 17 by unix service, Sep 13, 2012

new workaround:


install rollback /S/L/E

Comment 18 by Evan Lojewski, Oct 29, 2012

Please reopen if this is still an issue.
Status: Invalid

Created: 6 years 2 months ago by Andreas Michalak

Updated: 6 years 21 days ago

Status: Invalid

Followed by: 3 persons

Labels:
Priority:Medium
Type:Defect