Chameleon

Issue 301: nVidia ROM patching fails on newer cards

Reported by Stewart Adam, Nov 22, 2012

As per discussion on issue #99, I am reporting a new issue: it has 
been reported on several newer nVidia cards that ROM patching fails. 
In my case, I see the following:

GeForce GTX 580 -4095MB NV1ff [10de:1080]-[1462:2563] :: 
PciRoot(0x1)/Pci(0x1,0x0)/Pci(0x0,0x0) device number: 1
ERROR: dcbtable_version is 0x01
ERROR: nVidia ROM Patching Failed!

Note how the memory size is also incorrectly detected. Reproduced 
using latest trunk (I also tried ErmaC's trunk, same results).

Comment 1 by ErmaC , Nov 27, 2012

I doubled the NVIDIA_ROM_SIZE as you suggest in the other issue and 
do minus change in the nvidia header.

Pls test and report it.
Binaries attached.



Fabio

Comment 2 by ErmaC , Dec 16, 2012

ok applied on a temp trunk (2143) w8 for admin revision.
Hopefully was fixed.

Comment 3 by Stewart Adam, Dec 16, 2012

Sorry it took me so long to test, had some exams at school.

This change did resolve the ROM truncation error when using 
UseNvidiaROM=yes (#302) but it has not solved the incorrect memory 
size or ROM patching. I still get the error messages posted in the 
original issue when booting using r2143.

Comment 4 by ErmaC , Dec 17, 2012

I find (maybe) some useful info from nouveau project
relate to ROM:
http://comments.gmane.org/gmane.comp.freedesktop.xorg.nouveau/11086

ErmaC

Created: 6 years 7 months ago by Stewart Adam

Updated: 6 years 7 months ago

Status: New

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect