Chameleon

Issue 32: Chameleon displays wrong memory info in memory module

Reported by Zane Chua, Aug 28, 2010

Basically the problem is that Chameleon is unable to get information 
about the RAM in the system. I am not sure to what extent it is 
affected, but it seems like it only affects Slot 2 and above. For my 
case i have 2 x 2GB DDR3 1066 Ram but it detects one as 2GB DDR3 
1066 and the other as 2GB DDR 2 8

Comment 1 by Zane Chua, Aug 28, 2010

*other as 2GB DDR 2 800Mhz. Azimutz told me to report this. ;P

Comment 2 by Zane Chua, Aug 28, 2010

*other as 2GB DDR 2 800Mhz. So yeah. Azimutz told me to report this 
so i did. ;p

Comment 3 by Kabyl, Aug 28, 2010

Try the booter from this branch:
http://forge.voodooprojects.org/p/chameleon/source/tree/HEAD/branches
/Kabyl

Comment 4 by Zane Chua, Aug 28, 2010

Hold up. I don't have the source at the moment. Fetching the source 
via the SVN now.

Comment 5 by Zane Chua, Aug 28, 2010

Compiled boot from your branch with the tags Release, i386 and 10.6. 
I still get the same problem.

Comment 6 by Kabyl, Aug 28, 2010

upload an 'ioreg -lw0'

Comment 7 by Zane Chua, Aug 28, 2010

Here you go.

Comment 8 by Kabyl, Aug 28, 2010

OK, I see where the issue is, I just need to find sometime to fix it.

Comment 9 by Zane Chua, Aug 28, 2010

Awesome. :) Anything i can help with? Especially Tedious work, i 
wouldn't mind helping.

Comment 10 by Kabyl, Aug 28, 2010

How many memory slots do you have?

Comment 11 by Zane Chua, Aug 28, 2010

I have 2 memory slots. At least thats how many i saw when i opened 
the bottom of my laptop.

Comment 12 by Zane Chua, Aug 28, 2010

Or rather, how many rams i saw. Should have four but i assume that 
the other two brackets are not soldered on.

Comment 13 by Kabyl, Aug 28, 2010

Try this booter.

Comment 14 by Zane Chua, Aug 28, 2010

That certainly did fix it. Uploaded 2 images. One with smbios.plist 
data keyed in and one without.

Comment 15 by Zane Chua, Aug 28, 2010

Sorry for double posting for like 4 times. Damn mouse clicked too 
fast.

Comment 16 by Kabyl, Aug 28, 2010

nice, I will commit the fix later.

Comment 17 by Zane Chua, Aug 28, 2010

Hold up. Found out something. Your booter breaks CPU detection. Or 
is it because im using Azimutz's branch? When i place your branch my 
CPU gets detected as Intel Xeon. When i use Azimutz's branch my CPU 
is i7. i wonder if DSDT is the cause of this, but I'm not too sure. 

-Zane

Comment 18 by Kabyl, Aug 28, 2010

The CPU detection is the same as trunk, guess that needs some work 
too.

Comment 19 by Zane Chua, Aug 28, 2010

Yeah. If you need any information just ask. I'll provide to the best 
of my ability. :)

Comment 20 by Mammoth htommaM, Jan 4, 2011

Hello Kabyl and all,

First off, I have already tried the boater from comment 13 and it 
has no affect on the issue I'm reporting now.

In System Profiler, under Diagnostics, the Power On Self-Test always 
has "Result:   Failed" with "Failure Type: 
Memory".

This is on an HP Pavilion DV8 laptop (DV8t-1100, VF836AV)

CPU: Intel® Core™ i7-720QM 1.6GHz, 6MB, L2C
Memory: Installed: 4GB (2GB x 2GB) [Maximum: 8GB] Type/Speed: 
DDR3/1333MHz
Video: NVIDIA® GeForce® GT 230M GPU w/ 1024 MB
Sound: IDT 92HD75B3 Audio Controller
LAN: Realtek RTL8168D/8111D PCI-E Gigabit

Current BIOS version: InSyde F.25

- I have tried various versions of Chameleon (currently 
2.0-RC5-r674)
- Many different SMBIOS.plist settings
- Running with no DSDT or SMBIOS.plist
- 1 module, each slot

Nothing I have done has been able to correct this.

When I set the machine in SMBIOS.plist as a MacPro5,1, I am able to 
run the Memory Slot Utility (shown in attached picture). If set to 
other models I am NOT able to run this utility.

When Chameleon boots, It IDs the two SO-DIMMs as Slot 0 and Slot 2. 
(Shouldn't this be Slot 0 and Slot 1?)

I know for sure many others with similar machines are seeing the 
same issue. The main concern is that it may be preventing OS X from 
running the memory in dual channel mode, thus affecting performance. 


I have attached a screen shot showing the errors, and also a zip 
file with an IORegExp, SysProf, Bdmesg, and DSDT file.

I am more than willing to help in any way to get this resolved.

THANKS!!!

Comment 21 by Mammoth htommaM, Jan 4, 2011

Following is my most current research efforts:


I've continued to try to track this problem down, but have still 
been unable to solve it.

I have been able to install the machine as a MacBook Pro6,2, and now 
the slots show up as BANK0/Slot 1 and BANK1/Slot 2, as they should, 
but still have the failure message.

I have tried many DSDT's, and current is completely clean, no 
warnings, and pretty much everything working.

I believe the issue is either with BIOS or Chameleon, or a 
combination. I think this is something Chameleon needs to address 
with the funky Insyde BIOS.

In System Profiler, memory always shows up as 1330MHz. If you look 
at the BdMesg output (in zip file, previous post), you will see 
Chameleon detecting memory Frequency at 665 MHz (1330) instead of 
667 MHz (1333). I'm thinking this must be related to OS X believing 
this to be a failure with the memory not running as it should. In 
Windows 7 and in BIOS, memory is properly reported at 1333MHz. If I 
install 1066 modules, they are show incorrect too and we get the 
same error in SP.

Could someone on the Chameleon team look into this? I know you guys 
are REAL busy, but if you could help solve this, not only would it 
be great, but I am planning another guide and CD release for members 
of my thread on InsanelyMac and I would like to have this fixed for 
everyone.

Thanks.

Comment 22 by Mammoth htommaM, Jan 4, 2011

Ok, I don't mean to be a "serial poster" but I do have 
some more data points to share.

After trying the booter (not boater, as Safari kindly 
"corrected" for me) from comment 13, I decided to change 
to MacPro5,1 again in smbios.plist to see how the "Memory Slot 
Utility" saw the modules while running on top of this booter. 
Results, no change at all... ok, that's not exactly true.

I just checked and I see (as already reported) CPU detection now 
wrong (Quad-Core Intel Xeon, as opposed to i7 720 as previously 
detected). Also, and this is interesting, now I have the problem 
Zane repotted as having BEFORE using this booter, but was corrected 
with this booter:

BANK 0/Bottom - Slot 1 4 GB DDR3        1330 MHz
BANK 1/Bottom - Slot 2 4 GB DDR2 SDRAM   800 MHz

(plus, Slot 1 shows detection of Manu, Part, and S/N, but Slot 2 
just shows "N/A")

Comment 23 by Mammoth htommaM, Jan 4, 2011

Last post from me on this today.

I tried PC-EFI 10.6 and no change. I even created an smbios.plist 
with all correct values for CPU and memory and (of course), had no 
affect other than cosmetically.

Comment 24 by Mammoth htommaM, Jan 4, 2011

From Mammoth:
Question: How do we turn off memory detection? I would love to try 
that.

From BlackOSX:
Try adding the following in to your /Extra/com.apple.Boot.plist 
(I've never used this myself but I think it's the right boot 
option)..

<key>UseMemDetect</key>
<string>No</string>


From Mammoth:
Thanks for the info BlackOSX,

I tried UseMemDetect and discovered it cannot be used at the 
Chameleon command line (at least it ignored it for me). But it does 
work when used in the com.apple.Boot.plist, as you instructed. This 
however did not resolve the issue, so I am willing to bet it is a 
slot detection issue in Chameleon that has to be addressed in order 
to solve the issue for all HP DVx laptops.

Comment 25 by Mammoth htommaM, Jan 4, 2011

Question: What brand and model number was Zane Chua's laptop?

Comment 26 by Zane Chua, Jan 4, 2011

Lenovo Y550P. http://bit.ly/osx86log

I don't think this is the proper place to post your 
"findings". Have you tried using a iMac 11,1. Can't get 
you any of my files at the moment but maybe you would like to take a 
look at my site, I think I did upload a pretty basic 
com.apple.boot.plist. What intrigues me however is that our laptop 
specifications are almost similar.

Comment 27 by Mammoth htommaM, Jan 5, 2011

Thanks Zane for the info! You can check out my thread on 
InsanelyMac; we have made amazing progress and are very close to 
perfect machines:

http://www.insanelymac.com/forum/index.php?showtopic=221653

Comment 28 by Azimutz, Jan 6, 2011

Hi Zane.. sorry for this mess.
I pointed Daniel here from:
http://forum.voodooprojects.org/index.php/topic,1750.msg9224.html#msg
9224

and he thought he was on a forum... or whatever :P

See you around...

Comment 29 by Mammoth htommaM, Jan 6, 2011

Hey Zane, I have looked at your site and I'm still working on this. 
I don't know why Azimutz felt the need to make his previous post, 
but in his own words "whatever". Yeah, I thought it was a 
FORUM because... Oh, gee, I don't know, maybe because it's 
FORUM.voodooprojects..... whatever. I guess for some people the end 
of the world is just one more drop of water away. 8P

Comment 30 by Azimutz, Jan 6, 2011

Gee.. maybe because we are on FORGE.voodooprojects.org, on the 
"issue/bug tracker" of Chameleon project repository, issue 
32, that you just polluted transcribing a ton of stuff from a forum 
topic, when you could/should just have posted the link, like i did 
and stated your problem!?.. and we're not on a forum, online diary, 
blog, or "whatever" you think this is?!
Or maybe because it was me who pointed you here!?
Or just maybe because i know and respect Zane and it was also i who 
sent him here!?
Whatever the reason, i've helped what i could...

Comment 31 by Zane Chua, Jan 6, 2011

Hey Daniel, the reason why i said this probably isn't the correct 
place to post as this place is for debugging ONCE you have figured 
out the issue, Since you don't please keep it to the FORUM. Every 
post you make, i get an email. I know i can unsubscribe but since 
this hasn't been reported as fixed, i still want to be subscribed. 
Azi probably posted because he realized that i have received a lot 
of emails and probably wanted to apologize for that on YOUR behalf, 
please don't misunderstand Azi's well intentions.

Comment 32 by Cosmosis Jones, Jun 2, 2011

uh yeah.
Status: Duplicate

Created: 7 years 2 months ago by Zane Chua

Updated: 6 years 5 months ago

Status: Duplicate

Followed by: 4 persons

Labels:
Priority:Medium
Type:Defect