Chameleon

Issue 120: SMBIOS issue on ProductName

Reported by Cosmosis Jones, Jul 18, 2011

T7600 @2.33 ghz.


I think sergies commit busted the old cst/pst geneartion.

When i boot w/ 1051, i get correct tables, when i boot w/ trunk 
tables are generated, but not recognized by Coolbook/os.

Going to diff it.

Comment 1 by Cosmosis Jones, Jul 19, 2011

i removed generate c & p states from boot plist.
using bios ssdt.
using coolbookcontroller to display frequencies.

1051 & 1060 frequencies show fine
>1100 frequencies show as 0.

Comment 2 by Cosmosis Jones, Jul 19, 2011

Status: Accepted

Comment 3 by Cosmosis Jones, Jul 19, 2011

1070 == good

Comment 4 by Cosmosis Jones, Jul 19, 2011

1080 == good

Comment 5 by Cosmosis Jones, Jul 19, 2011

1090 == good

Comment 6 by Cosmosis Jones, Jul 19, 2011

1095==good

Comment 7 by Cosmosis Jones, Jul 19, 2011

1130 == bad

Comment 8 by Cosmosis Jones, Jul 19, 2011

1097 == good

Comment 9 by mozo, Jul 19, 2011

Please, attach your chameleon's generated SSDTs old and new.

Comment 10 by Cosmosis Jones, Jul 19, 2011

I don't know if it has to do w/ genreation at all now..
I've removed all SSDT amls, removed the Genrate flags, and am going 
w/ just the bios stuff.

I think it might be something w/ teh relocation of the tables.

But sure i will do that ;)

Comment 11 by Cosmosis Jones, Jul 25, 2011

This isi actually totally wrong.. IT has to do w/ Smbios

I have mine set to MacBookPro7,1
CoolBook2.kext/Contents/Info.plist matches on that explicit name.. 
but it fails on any rev > 1100

Changing the plist to match on 7* worked..

Therefore this is truly an SMBIOS issue
Summary: SMBIOS issue on ProductName

Comment 12 by Cosmosis Jones, Jul 28, 2011

Labels: Target:2.1 Target:2.0

Comment 13 by Cosmosis Jones, May 8, 2012

Status: Invalid

Created: 3 years 5 months ago by Cosmosis Jones

Updated: 2 years 7 months ago

Status: Invalid

Owner: Cosmosis Jones

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect
Target:2.1