Chameleon

Issue 122: Memory-related info in smbios.plist not being read

Reported by Konstantinos Giannakas, Jul 19, 2011

Hello to all developers, thank you for your excellent and continuing 
work on Chameleon.

For many builds now (from the trunk) there seems to be a problem 
parsing the data in smbios.plist related to memory configuration, 
namely:

SMmembankloc_1 to SMmembankloc_4 or 8
(usually set as string "BANK 0" etc.)

SMmemdevloc_1 to SMmemdevloc_4 or 8
(usually set as string "DIMM0" etc.)

SMmemmanufacturer_1 to SMmemmanufacturer_4 or 8
(usually set as string "OCZ Inc." etc.)

SMmemserial_1 to SMmemserial_4 or 8
(usually set as string "0x0000102AE20021" etc.)

Perhaps also SMmempart_3 is not being read/injected, but I cannot 
know as Chameleon detects the part number of the memory module and I 
never tried to inject a totally bogus string.

I've been using such a longer version of smbios.plist as Chameleon 
doesn't detect the serial number of my Kingston RAM modules and 
also, instead of having "Bank0/1/A0" in System Profiler, I 
can get the official "BANK 0/DIMM0" like real Macs.

I would appreciate a confirmation on this issue and a fix for this 
problem.

P.S. I have modified all misspelled sections "manufacter" 
to "manufacturer".

Thank you in advance.

Comment 1 by Konstantinos Giannakas, Jul 19, 2011

EDIT: I mean before SMmempart_1 to SMmempart_4 etc. not specifically 
SMmempart_3. The actual part no. of the module (of any RAM module) 
perhaps it's not being properly injected. Sorry for the typo.

Comment 2 by Cosmosis Jones, Aug 2, 2011

please post a bdmesg as well

Comment 3 by Konstantinos Giannakas, Aug 2, 2011

Hello Cosmosis Jones, thank you for your mail. This is my bdmesg 
with current Chameleon svn-r1252 attached.

Comment 4 by Konstantinos Giannakas, Aug 3, 2011

As you can see, for memory I set the string in smbios.plist file to:

manufacturer = "OCZ Inc."
bankLocator = "BANK 0/DIMM0"
serialNumber = "0x0000102001"
partNumber = "OCZ2B800C52G"
among other memory things.

But these are not parsed, anymore... They used to work, however...

Thanks.

Comment 5 by d00d, Aug 4, 2011

I have a similar issue.
With r699 and 10.6.8 smbios.plist memory settings for 8 of the 12 
slots were reflected in System Profiler.
With r1187 and 10.6.8 or 10.7.0 smbios.plist memory settings for 
none of the 12 slots are reflected in System Profiler.
With r1233 and 10.7.0 smbios.plist memory settings for none of the 
12 slots are reflected in System Profiler (smbios.plist and 
bdmesg.out attached).

Comment 6 by Cosmosis Jones, Aug 15, 2011

http://forge.voodooprojects.org/p/chameleon/issues/120
Labels: Target:2.1
Status: Accepted

Comment 7 by Konstantinos Giannakas, Nov 13, 2011

Just to inform dear members of the project that this problem is 
still not solved with rev1684 that I have recently started using... 
Thanks.

Comment 8 by Cosmosis Jones, May 8, 2012

Status: Duplicate

Comment 9 by Jay Walker, Dec 7, 2013

This issue is now fixed via a new option switch

ForceFullMemInfo=Yes

Please see issue 361 for further info:-

http://forge.voodooprojects.org/p/chameleon/issues/361

Created: 3 years 1 month ago by Konstantinos Giannakas

Updated: 8 months 20 days ago

Status: Duplicate

Followed by: 3 persons

Labels:
Priority:Medium
Type:Defect
Target:2.1