Chameleon

Issue 130: Chameleon breaks Facetime

Reported by Guest Guest, Jul 26, 2011

Steps to reproduce the problem:
1. Fix en0 in your DSDT, so Facetime works at all. Just doing this 
fix enables Facetime in XPC. 
http://www.projectosx.com/forum/index.php?showtopic=60
2. Boot into Chameleon, try to sign into Facetime. Build 775 
supports it, all laters don't.
3. Cry as you can't use a feature (Facetime) that no one uses.

Expected result: You can stare at a Window, waiting for someone to 
facetime you.

Actual result: You stare at a window telling you that you can't sign 
in.

Comment 1 by Cosmosis Jones, Jul 28, 2011

did you use EthernetBuiltIn w/out doing a dsdt fix?

Comment 2 by Cosmosis Jones, Jul 28, 2011

and what is your asl code for "fixing" en0. Thats kinda a 
generic statement.

Comment 3 by Hell Fish, Jul 29, 2011

This is well documented here:
http://www.insanelymac.com/forum/index.php?showtopic=261423

You don't need to fix DSDT, you can use EthernetBuiltIn=Yes as well, 
but FaceTime support requires on or the other.  However...

*only* r755-r760 of chameleon allow FaceTime to work.  All later 
versions cause the server error regardless of ethernet fix in DSDT 
or boot.plist.

After initial FaceTime setup using r755, one can then update 
chameleon to a later version, and FaceTime will continue to work 
unless you disable her.  Then, if you reenable, you must downgrade 
back to r755 of setup again.

Comment 4 by Cosmosis Jones, Jul 29, 2011

so have you compared your ioreg settings between r755 and every 
other one. Would be nice to find the difference in order to make it 
work.

It coudl also be related to smbios as well.

Can you get bdmesgs between both booters as well.
So bdmesgs and ioregs.
Labels: Target:2.0

Comment 5 by Cosmosis Jones, Aug 2, 2011

This is not a booter issue. This is happening on real macs as well 
and has something to do w/ certificates. Most likely, when you boot 
with such an old version of chameleon, it triggers the os to regen 
or resign new certs.
Status: Invalid

Comment 6 by Carlos Rodríguez, Aug 2, 2011

I think this issue needs to be reconsidered.

You're giving us the reason by telling us that with the r755 the 
booter triggers the OS to regen the certificates.

I've already tried with so many versions of Chameleon and Chimera 
and only with r755 I can use facetime.

By looking at IOreg I don't see any apparent differences but I don't 
know how to use bdmsesg. If you tell me how to do that, I will 
attach the IOreg dumps and bdmesgs.

Cheers!

Comment 7 by Henry Guzman, Aug 22, 2011

i too have had the same problem. FaceTime is only able to login 
using r755. Once logged in i can replace the boot file, but if i 
sign out of FaceTime i will get error until i replace boot file with 
755 again.

Comment 8 by Carlos Rodríguez, Sep 2, 2011

Thank God it's fixed on r1493!!! Works flawlessly.

I was sure the bootloader was the culprit. Now it works fine.

Thanks!

Comment 9 by Hell Fish, Sep 2, 2011

Carlos!  Thanks for posting.  Yes, it is finally fixed with r1493 
for me as well.  Sweet!

Created: 7 years 11 months ago by Guest Guest

Updated: 7 years 10 months ago

Status: Invalid

Followed by: 5 persons

Labels:
Priority:Medium
Type:Defect
Target:2.0