Chameleon

Issue 150: Chameleon freezes

Reported by Ivanov, Aug 18, 2011

Steps to reproduce the problem:
1. boot chameleon
2. select a drive
3. chameleon hangs

Expected result:
Read the kexts and boot

Actual result:
It was working good, but one day out of the blue it started to hangs 
after reading a couple of Info.plists from the system kexts. By 
freezing i mean chameleon reads the first 10-12 kexts and then 
freezes - no HDD activity, no progress, nothing. I tried removing 
the kext where it froze (AppleHWSensor), but then it froze on the 
next one (ApppleUSBHID). The freeze is BEFORE it boot the kernel 
i.e. when its reading the kexts properties:

Read HFS+ file: .... (XXX bytes)

Chameleon was booting fine yesterday, even injecting Nvidia string 
was working. Today for no reason it can't boot.

My kexts in Extra are:
FakeSMC
AppleAHCIInjector
ApplePS2
AppleRTC

I also tried booting with bare minimum (FakeSMC) - freezes  again.

Tested versions: r1113, r1395, r752 - not working all of them freeze

Older versions (RC3/RC4) can boot, but they are not compatible with 
Lion and the result is KP.

Comment 1 by Ivanov, Aug 19, 2011

You can close (delete) the report it turned out that my partition 
was corrupted.

However as a possible future request it can be handy if chameleon 
can tell us if there is something wrong.

Comment 2 by Cosmosis Jones, May 8, 2012

Status: Invalid

Created: 8 years 3 months ago by Ivanov

Updated: 7 years 6 months ago

Status: Invalid

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect