Chameleon

Issue 59: Memory speed incorrectly detected - Power On Self-Test: Failed - Memory

Reported by Mammoth htommaM, Jan 16, 2011

On i7 HP Pavilion DVx series laptops (VF836AV), memory is detected 
incorrectly:

"Speed: 1330 MHz" instead of "1333"

(Also incorrect with 1066 memory installed.) 

Always in System Profiler, a memory failure of both memory modules 
is displayed:

Power On Self-Test: Failed
Failure Type:       Memory

This has been verified on many machines.

Comment 1 by Cosmosis Jones, Jun 2, 2011

please reopen if still issue
Status: Invalid

Comment 2 by Mammoth htommaM, Jun 22, 2011

I have tried the latest version of Chameleon 1033, and several 
branches, and this issue still exsits. If there is a particular 
version or branch which resolves this issue, let me know and I will 
try that, then report back. Thanks.

Comment 3 by Cosmosis Jones, Jun 22, 2011

Please attach a BDmesg output ( A current one thanks)
Status: Accepted
Owner: cosmo1t

Comment 4 by Cosmosis Jones, Jun 22, 2011

Also are u using a smbios.plist?

Comment 5 by Cosmosis Jones, Jul 18, 2011

Labels: Target:2.1

Comment 6 by Geoff Seeley, Apr 29, 2012

I believe the speed calculation issue has been resolved for some 
time, but I have determined the cause and solution to the error 
issue:

Power On Self-Test: Failed
Failure Type:       Memory

Looking at the SMBIOS from HP DV8-1093ca (under linux) that has 
2x4GB SODIMMs:
-----------------------------------------
# dmidecode 2.11
SMBIOS 2.6 present.
...
Handle 0x0016, DMI type 16, 15 bytes
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: None
	Maximum Capacity: 8 GB
	Error Information Handle: No Error
	Number Of Devices: 2

Handle 0x0017, DMI type 17, 28 bytes
Memory Device
	Array Handle: 0x0016
	Error Information Handle: 0x0018
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 4096 MB
	Form Factor: SODIMM
	Set: None
	Locator: Bottom - Slot 1
	Bank Locator: BANK 0
	Type: DDR3
	Type Detail: Synchronous
	Speed: 1067 MHz
	Manufacturer: Samsung
	Serial Number: XXXXXXXX
	Asset Tag: Unknown
	Part Number: M471B5273BH1-CF8  
	Rank: Unknown

Handle 0x0018, DMI type 18, 23 bytes
32-bit Memory Error Information
	Type: OK
	Granularity: Unknown
	Operation: Unknown
	Vendor Syndrome: Unknown
	Memory Array Address: Unknown
	Device Address: Unknown
	Resolution: Unknown

Handle 0x0019, DMI type 20, 19 bytes
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000FFFFFFFF
	Range Size: 4 GB
	Physical Device Handle: 0x0017
	Memory Array Mapped Address Handle: 0x001E
	Partition Row Position: 2
	Interleave Position: 1
	Interleaved Data Depth: 1

Handle 0x001A, DMI type 17, 28 bytes
Memory Device
	Array Handle: 0x0016
	Error Information Handle: 0x001B
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 4096 MB
	Form Factor: SODIMM
	Set: None
	Locator: Bottom - Slot 2
	Bank Locator: BANK 1
	Type: DDR3
	Type Detail: Synchronous
	Speed: 1067 MHz
	Manufacturer: Samsung
	Serial Number: XXXXXXXX
	Asset Tag: Unknown
	Part Number: M471B5273BH1-CF8  
	Rank: Unknown

Handle 0x001B, DMI type 18, 23 bytes
32-bit Memory Error Information
	Type: OK
	Granularity: Unknown
	Operation: Unknown
	Vendor Syndrome: Unknown
	Memory Array Address: Unknown
	Device Address: Unknown
	Resolution: Unknown

Handle 0x001C, DMI type 20, 19 bytes
Memory Device Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x000FFFFFFFF
	Range Size: 4 GB
	Physical Device Handle: 0x001A
	Memory Array Mapped Address Handle: 0x001E
	Partition Row Position: 2
	Interleave Position: 2
	Interleaved Data Depth: 1

Handle 0x001D, DMI type 18, 23 bytes
32-bit Memory Error Information
	Type: OK
	Granularity: Unknown
	Operation: Unknown
	Vendor Syndrome: Unknown
	Memory Array Address: Unknown
	Device Address: Unknown
	Resolution: Unknown

Handle 0x001E, DMI type 19, 15 bytes
Memory Array Mapped Address
	Starting Address: 0x00000000000
	Ending Address: 0x001FFFFFFFF
	Range Size: 8 GB
	Physical Array Handle: 0x0016
	Partition Width: 2
-----------------------------------------
You can see that HP includes a memory error handle for each DIMM 
(Handle 0x001B and 0x001D). According to the SMBIOS 2.6.1 reference 
specification, this is allowed and one of the "error 
types" for a memory handle is "OK" (or no memory 
error). Kind of goofy standard if you ask me as an error means an 
error in my book. This is probably what the Apple engineers thought 
because I've been able to prove that if you set the memory error 
handle to 0xFFFF (no error was detected) in both DMI type 16 
records, System Profiler correctly displays:

Power On Self-Test: Passed

For my test (diff attached) I just hard coded the memory error 
handle but I think the correct solution is:

if memoryErrorHandle < 0xFFFE then
	get memoryErrorInformation
	if memoryErrorType = OK then
		memoryErrorHandle = 0xFFFF
	end
end

Comment 7 by Cosmosis Jones, Oct 29, 2012

No Movement.
Status: Invalid

Created: 3 years 11 months ago by Mammoth htommaM

Updated: 2 years 1 month ago

Status: Invalid

Owner: Cosmosis Jones

Followed by: 2 persons

Labels:
Priority:Medium
Type:Defect
Target:2.1