Chameleon Applications

Issue 111: GUI .png Alpha Mask Blending.

Reported by blackosx, Jul 13, 2011

Chameleon currently uses two screens for the GUI. The first being 
the 'Timeout' screen used for showing the default boot device, along 
with the 'countdown' text and progress bar. The second being the 
'Device Selection' screen where the user can choose which device to 
boot, view the menu and type boot options.

Device graphics are drawn differently on the 'Timeout' screen 
compared against the 'Device Selection' screen, with the 'Timeout' 
screen showing them correctly and shows them as they look in 
Photoshop. However, when the same image is drawn on the device 
selection screen it's 'blended' differently which results in the 
transparent pixels effectively disappearing.

This affects any .png drawn within the 'Devicelist Window ' (taken 
from gui_t struct in /i386/boot2/gui.h) boundary in the 'Device 
Selection' screen. So that includes the device graphics and the font 
.png used for the device names.

To demonstrate this, I have a created a test theme (see attached). 
The lowest resolution to use it with should be 1024x768 and I 
recommend using the timeout boot option set to a high value, say 30 
to give time to read the screen.

Other posted screenshot examples:
http://forum.voodooprojects.org/index.php/topic,1432.msg7883.html#msg
7883
http://forum.voodooprojects.org/index.php/topic,1432.msg7888.html#msg
7888

The problem here mainly rears it's head because Chameleon uses both 
the 'Timeout' and 'Device Selection' screen. Maybe if the 'Timeout' 
screen was no longer used then this problem wouldn't be noticed? 
(the graphics would still be drawn incorrectly on the 'Device 
Selection' screen, but there wouldn't be anything to compare them 
against (though it would be preferable if this issue could be fixed 
and the graphics appear as intended.)).

This post
http://forum.voodooprojects.org/index.php/topic,1904.0.html
might be on the right lines suggesting not using the 'Timeout' 
screen, but instead drawing the progress bar underneath the default 
device icon on the 'Device Selection' screen. Maybe a possible 
option if the GUI were ever to be redesigned / re-thought?

Comment 1 by blackosx, Jul 13, 2011

Please remove this issue from Chameleon Applications as I 
accidentally posted it here. It's since been posted to the Chameleon 
issues.

Comment 2 by ErmaC , Sep 5, 2011

Status: Invalid

Created: 9 years 3 months ago by blackosx

Updated: 9 years 1 month ago

Status: Invalid

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect