Chameleon

Issue 104: Raid0 is not working in Lion.

Reported by Tommy mui, Jul 7, 2011

The chameleon seems fail to handover the extensions to the raid 
drive. It's working by loading a non-raid drive first, and enter the 
raid lion by uuid. The remedy is to create extensions.mkext and 
mach_kernel and leave in the extra in efi partition.

Comment 1 by Luis Galhardo, Jul 7, 2011

I have the same problem, it seems chameleon ignores the new 
kernelcache on 
/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache but 
if I use: kextcache -v -l -m /Volumes/Boot\ 
OSX/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mk
ext" /System/Library/Extensions /Extra/Extensions
Then chameleon boots fine and loads extensions.mkext instead of 
kernelcache. Chameleon UseKernelCache=Yes makes no difference.

Comment 2 by Luis Galhardo, Jul 7, 2011

Correction: Where it reads: 

I have the same problem, it seems chameleon ignores the new 
kernelcache on 
/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache

I'm referring to the raid helper partition

Comment 3 by Evan Lojewski, Jul 8, 2011

I'll try to take a look at it this week
Owner: meklort

Comment 4 by Tim OBrien, Jul 16, 2011

Any progress on this ?

Comment 5 by Cosmosis Jones, Jul 18, 2011

Status: Accepted

Comment 6 by Cosmosis Jones, Jul 18, 2011

Labels: Target:2.0

Comment 7 by Crna Brada, Jul 21, 2011

Evan,

Has anybody else looked at this problem too? I understand that you 
have zillion of things to do and I appreciate very much your effort 
to help us.

Kind regards

Comment 8 by Luis Galhardo, Jul 21, 2011

This should already be fixed by now :(     Any ETA ?

Comment 9 by Evan Lojewski, Jul 21, 2011

It'll get fixed after someone looks into it. I haven't had time to 
yet (and it's not a high priority for me). I will get to it 
eventually, it just might take a while.

Comment 10 by Luis Galhardo, Jul 21, 2011

Thanks for the update Evan

Comment 11 by Tim OBrien, Jul 22, 2011

Thanks for the update.

Comment 12 by mozo, Jul 22, 2011

Could confirm, chameleon can't load kernel cache from boot helper 
partition. Also seems org.chameleon.Boot.plist settings ignored then 
booting from soft-RAID. Other stuff (dsdt, smbios) loading ok from 
Extra on boot helper partitions.

small changes on boot2 stage loader in boot.c file and lion works 
(can't test in snowleo cos I don't have so many disk for RAIDs for 
tests :)

Comment 13 by mozo, Jul 22, 2011

* seems only kernel boot flags is ignored

Comment 14 by And G., Jul 23, 2011

Hey mozodojo, 

With your patch I can get past the kernel panic because of the 
missing kernelcache.

However, it seems like it's not loading /Extra/Extensions? (ie. I 
get stuck in eternal boot screen with turning wheel)

Comment 15 by And G., Jul 23, 2011

Chameleon does list FakeSMC when booting, but "FakeSMC: 
Opensource SMC device emulator by netkas (C) 2009" is missing, 
so it gets stuck at "Waiting for DSMOS...".

Comment 16 by mozo, Jul 23, 2011

Then the core is loading from kernelcache chameleon can't handle 
properly Extra/Extensions.

Comment 17 by Trauma Tron, Jul 24, 2011

On my side chameleon always look for the kernel, and never loads 
kernelcahce. Since Lion,the boot helper partition don't contain 
anymore the kernel, so i had to add it manually. I'm also forced to 
use a mkext to load Lion on the raid setup.

Even with mozo's fix it's not working. 

I'm using a dedicated Chameleon partition, that load boot helper 
partition.

Comment 18 by Crna Brada, Jul 24, 2011

Not sure if my experience could help, but here it is. 
I independently installed Lion on RAID0 and also on a memory stick. 
BIOS is pointing to memory stick from which the Chameleon starts. 
Boot.plist on memory stick however points to uuid of the RAID. Lion 
install and updates work just fine, without need to use any SL 
fall-back tricks (e.g. creation of SL style Extensions.mkext etc). 

Cannot try modjo's fix for another week until I come home from 
vacation. 

Hope this helps.

Comment 19 by And G., Jul 24, 2011

Well after compiling Chameleon with boot.c from mozodojo it works 
perfectly for me without any fall-back tricks, all I need is to add 
FakeSMC to /S/L/E.

Comment 20 by Crna Brada, Jul 24, 2011

Guys,

Sorry for asking a question that seems to be trivial for all of you. 
Are there any instructions how to compile Chameleon?

I would guess you have to run a make file from a directory. Do you 
need XCode to be installed too?

Thanks

Comment 21 by And G., Jul 24, 2011

Yes, you need XCode. Just open the XCode project file and compile it.

Comment 22 by Thom S, Jul 25, 2011

I see that the current revision (1221) reverts the changeset 1214 
which introduced the modification from mozodojo in comment #12. I do 
not know details about this revert but I just wanted to let you know 
because I just wanted to start testing this... Now I am also going 
to wait until a more generic fix will appear

Comment 23 by Luis Galhardo, Jul 25, 2011

I'm using the current version with UseKernelCache=Yes flag on 
Chameleon. It now boots fine from my raid 0. Thanks

Comment 24 by Cosmosis Jones, Jul 25, 2011

That code from mozo had an explicit OSCheckversion in boot.c
That wasn't a real problem, more against what we are trying to do by 
making this a generic bootloader.

The problem of the code was the assignment to the gKernelCache file 
(it caused bootFile) to be null later on.

Comment 25 by d00d, Jul 25, 2011

In 10.6.8 -v is ignored (RAID0);
http://forum.voodooprojects.org/index.php/topic,2108.0.html

Comment 26 by mozo, Jul 25, 2011

Cosmosis Jones, don't sure I really understand what you said. 

The problem is that no more mach_kernel on Lion's boot helper 
partitions. Only kernelcache located in 
/System/Library/Caches/com.apple.kernelcaches/ inside the 
com.apple.boot.P(S,R)

Comment 27 by mozo, Jul 25, 2011

I see you reverted my changes. So Lion on my soft-raid no more 
bootable with trunk using? :)

Comment 28 by mozo, Jul 25, 2011

Tested now, of course there is no miracle. My soft raid is not 
bootable with this version. Thanks.

Comment 29 by Luis Galhardo, Jul 25, 2011

mozodojo, thanks for the patch. I will keep using it until better 
solution. It boots, that's what I wanted :)

Comment 30 by Evan Lojewski, Jul 25, 2011

mozodojo, the change was reverted because it breaks non softraid 
machines.

Comment 31 by mozo, Jul 25, 2011

if (checkOSVersion("10.7"))
            {
                bootFile = gBootKernelCacheFile;
            }
            else
            {
                sprintf(bootFile, "%s/", 
bootInfo->bootFile);
            }
            
            // Try to load kernel image from alternate locations on 
boot helper partitions.
            sprintf(bootFileSpec, "com.apple.boot.P%s", 
bootFile);
            ret = GetFileInfo(NULL, bootFileSpec, &flags, 
&time); 
            if (ret == -1)
            {
                sprintf(bootFileSpec, 
"com.apple.boot.R%s", bootFile);
                ret = GetFileInfo(NULL, bootFileSpec, &flags, 
&time); 
                if (ret == -1)
                {
                    sprintf(bootFileSpec, 
"com.apple.boot.S%s", bootFile);
                    ret = GetFileInfo(NULL, bootFileSpec, 
&flags, &time); 
                    if (ret == -1)
                    {
                        // No alternate location found, using the 
original kernel image path.
                        strcpy(bootFileSpec, bootInfo->bootFile);
                    }
                }
            }

Comment 32 by d00d, Jul 26, 2011

I updated to 10.7.0 using v1220, but mozodojo's boot.c RAID fix 
didn't work in my case.
Here's what worked after booting from a 10.6 USB flash drive and 
doing the following (-v is still ignored from 
org.chameleon.Boot.plist).
# diskutil list 
# diskutil mount disk0s3
# cp /Volumes/mac05/mach_kernel /Volumes/Boot\ OSX/
# kextcache -v 1 -t -m /Volumes/Boot\ OSX/Extra/Extensions.mkext 
/Volumes/mac05/System/Library/Extensions/
# diskutil unmount disk0s3
# diskutil mount disk1s3
# cp /Volumes/mac05/mach_kernel /Volumes/Boot\ OSX/
# kextcache -v 1 -t -m /Volumes/Boot\ OSX/Extra/Extensions.mkext 
/Volumes/mac05/System/Library/Extensions/
# diskutil unmount disk1s3

Comment 33 by Mark S, Jul 29, 2011

I had trouble on one drive getting the Extentions.mkext to work but 
it didn't solve my issue, however I didn't try the mozodojo's fix 
either.
I'll just boot off a external HDD pointing back to my raid 
identifier until something solid comes out.

Thanks for all the troubleshooting.

Comment 34 by Cosmosis Jones, Jul 30, 2011

mozodojo

Would it be better to set another flag to force this line in your 
code:

if (newFlag && checkOSVersion("10.7"))
		            {
		                bootFile = gBootKernelCacheFile;
		            }
		            else

Comment 35 by Cosmosis Jones, Jul 30, 2011

becuaswe i tested your change w/ non softraid on lion and it doesn't 
boot. I'd like to fix this generically, but i'm guessing we'd need 
another flag and not just check if it's lion.

Comment 36 by Cosmosis Jones, Jul 30, 2011

Owner: cosmo1t

Comment 37 by mozo, Jul 30, 2011

I also tested on non soft raid disk, lion boots without issues. 
Also, booting from non softraid volume  with this patch allows to 
boot raid0 volumes by choosing it from menu. The important thing is 
here  

// No alternate location found, using the 
original kernel image path.
strcpy(bootFileSpec, bootInfo->bootFile);

See changes in my branch.

Should work. Did you tried boot file from my branch?

Comment 38 by Cosmosis Jones, Jul 30, 2011

no i tried your patch on the trunk locally and it just does nothing. 
i'll try compiling your branch. is there some other change other 
than boot.c that is allowing yours to boot on non soft raids?

Comment 39 by mozo, Jul 30, 2011

rev1233 that is only changes I've made. My first attempt in trunk 
was incomplete as we see now.

Comment 40 by Tim OBrien, Aug 1, 2011

I had never compiled anything before ......
It took a few attempts but I got it. Rev1233 boots from RAID0 helper 
partition kernelcache ! I hope I didn't break some rule by putting 
it on kexts.com. It's there for now.

Comment 41 by Thireus, Aug 1, 2011

Tim, what do you mean by "RAID0 helper partition 
kernelcache" please?

Comment 42 by Tim OBrien, Aug 1, 2011

When setting up RAID in osx, disk utility creates a raid boot 
partition on each drive. That partition contains necessary boot info 
that would normally be read from the main partition on a single non 
raid drive. Items such as: chameleon boot file, kernel, kernel 
cache, boot.plist, chameleon extra folder, etc. 
Identifier would be disk number "X" "s" 
partition "3"   example 0s3. To mount the partition, in 
terminal write: diskutil mount disk0s3

Comment 43 by Mark S, Aug 1, 2011

Tim, thanks for building that.  I was trying but it kept saying I 
was missing /usr/bin/make on 3 different machines.  It got farther 
but I suspect its missing Kaybl's ATI tweaks, as it just stops right 
about the time I should see the video kick in.  I've got a ATI 5770 
Apple card in my machine.

Comment 44 by Cosmosis Jones, Aug 1, 2011

missing kabyl's ati tweaks?? Those were mereged to the trunk about 3 
months ago.
Also if you are missing /usr/bin/make you didnt' install xcode.

Comment 45 by Mark S, Aug 1, 2011

Weird, well I installed Xcode on 3 different machines thinking 4.0+ 
was the issue.  Each machine said I was missing /usr/bin/make when 
I'd hit 'build'.  Tried on Leopard, Snow and Lion.

I'll try pulling from SVN again, maybe I missed something.
Error: make: *** No rule to make target `%.c', needed by 
`/Users/Mark/Desktop/mozodojo'.  Stop.
Command /usr/bin/make failed with exit code 2


I used TonyMac's Chimera build, and the system boots ok as long as I 
do the aforementioned pointer from a external drive back to my raid 
array.

Comment 46 by Luis Galhardo, Aug 1, 2011

I don't build using Xcode app, I use Terminal and "make" 
to compile it.

Comment 47 by Mark S, Aug 1, 2011

I found the problem.  SVN client put "mozodojo (branch)" 
as the folder name and it was goofing up the build process.  Build 
successful now, I'll try it out and report back.
Thanks for assistance and work on this.

Comment 48 by Mark S, Aug 1, 2011

Well it still stalls out for me about the time the video should show 
up.  RAID is responding though.  I assume its a ATI support issue 
between this branch and Chimera's.  I attempted to update the boot.c 
with these fixes but there were far to many issues (137 of them) 
trying to compile Chimera.  Hopefully they pick up the fix down the 
road and push a build out.  In the mean time I'll external drive it.

Thanks

Comment 49 by Cosmosis Jones, Aug 2, 2011

so back to basics here..
Does this work on the trunk or not.

Comment 50 by Trauma Tron, Aug 2, 2011

No it's not working, I've even tested mozo's branch and the bug 
remain the same, bootfile is null, at least when booting from 
dedicated chameleon partition.

Didn't tested from boot helper, but according to everyone it seems 
to be ok.

Another strange behavior is if you point another Lion partition it 
will load bootfile or BootKernelCacheFile and then point to the 
boot-uuid of the raid volume... I know it's wiered but several 
poeple noticed this behavior.

Cheers.

Comment 51 by Mark S, Aug 2, 2011

I merged mozo's with the trunk and built and it did the same thing.  
Loads then seems to stop at the screen I'm attaching.

Comment 52 by Cosmosis Jones, Aug 2, 2011

well if it's video that doesn't help us much.. 
If you have ATI you need to set the AtiConfig and graphicsEnabler.

Can u ssh into the machine when it's like that? or use apple remote 
desktop and connect?

Comment 53 by Mark S, Aug 2, 2011

I've got both of those in the org.chameleon.Boot.plist from my Snow 
Leopard build.  It works ok with Chimera via TonyMac by way of the 
external drive linking back to the raid-uuid.
I don't see the machine appear on the network, and if I plug in a 
USB Drive I see it post in the log.  HDD activity halts after that 
last line.

Comment 54 by Cosmosis Jones, Aug 2, 2011

chimera is just a branch of chameleon.
what ahpepens if you use the trunk on extrenal and link back to uuid

Comment 55 by Mark S, Aug 2, 2011

This didn't work. It stalled out at the same spot. I decided to -v 
and -f for good measure and it booted. 
I then decided to boot from helper partition the same way. It never 
fully loads the S/L/E like it does on the external. My LAN never 
registers and it hangs. Hope that helps.

Comment 56 by Mark S, Aug 2, 2011

Based on what I'm seeing this build uses the entire S/L/E off the 
External Hard Drive, where as the last Chimera build seems to use 
the kernel cache off the RAID.  I only figured this out because I 
never rolled back the AudioHDA on my external HDD, and when I boot 
up now I have no sound.

Comment 57 by d00d, Aug 3, 2011

Thanks mozodojo, r1233 works with 10.7.0 and OS X software RAID1, 
using UseKernelCache=yes in org.chameleon.Boot.plist and without the 
two workarounds I listed.
Kernel flags such as arch=i386 and -v in org.chameleon.Boot.plist 
are still ignored however.

Comment 58 by d00d, Aug 3, 2011

I also ran into the `unable to find /usr/bin/make' compile error, 
and that was fixed by updating to Xcode 4.1.

Comment 59 by Mark S, Aug 3, 2011

Is there a easy way to rebuild that kernel cache on the helper 
partitions?  Mines still ignoring LAN and Audio and just hangs.  I 
tried Chameleon 1260 and Mojo's.  I can still boot of a External for 
now.

Comment 60 by And G., Aug 3, 2011

OS X should rebuild and update helper partitions when it detects a 
change in /S/L/E. So you can force a rebuild for example if you 
rename a kext. Not sure if there is a console command.

Comment 61 by And G., Aug 3, 2011

OS X should rebuild and update helper partitions when it detects a 
change in /S/L/E. So you can force a rebuild for example if you 
rename a kext. Not sure if there is a console command.

Comment 62 by d00d, Aug 3, 2011

The command is;
sudo touch /System/Library/Extensions/

Comment 63 by Mark S, Aug 3, 2011

Thanks, I ran that and can see the helper partition rebuilding *.P 
or *.R when I do that.
I updated to 1266, moved the boot file to both disk0s3, and disk1s3, 
Extra folders in place and added the UseKernelCache flag to the 
org.chameleon.Boot.plist.
What I see happening is it uses the kernel cache, then I see it go 
thru the kexts in the /Extra folder.  When it starts to post, I 
never see my LAN (Realtek) or Audio come online.  It's like its 
loading the base /S/L/E but ignoring the kexts in Extra.  So what I 
thought was a video issue, looks more like all the goodies in Extra 
are being ignored for some reason.
When I boot off the external drive I see FakeSMC, LAN and Audio 
initialize against the RAID Array.

Comment 64 by d00d, Aug 3, 2011

From BootHelp.txt;
UseKernelCache=Yes|No   Default is No. Yes will load pre-linked 
kernel and will ignore /E/E and /S/L/E/Extensions.mkext.

A solution is to move your kexts to SLE.

Comment 65 by d00d, Aug 3, 2011

Mark S, did you use v1266 or mozodojo's raid fix branch like the 
following;
svn co -r 1233 
http://forge.voodooprojects.org/svn/chameleon/branches/mozodojo

Comment 66 by Mark S, Aug 3, 2011

I pulled v1266 this morning and built.  I moved my /E/E/ to /S/L/E/ 
and she booted up fine.  I liked the abstraction of E/E/ but I have 
to roll back the AppleHDA any time it updates so not a big deal.
She posts fine now.  Thanks!

Comment 67 by d00d, Aug 3, 2011

Mark S, that's odd because r1266 is trunk and it doesn't have 
mozodojo's raid fix.
Are you booting off of the RAID or external drive?

Comment 68 by Mark S, Aug 3, 2011

RAID.  I pulled Mojodojo's 1266. If that doesn't have the fix, it 
looks like it works just by using the kernel cache by itself, but I 
had to do what we talked about and put my extensions into /S/L/E 
then touch that location.

Comment 69 by Mark S, Aug 3, 2011

Excuse me: mozo's not mojo.  
Verified, no USB Drive plugged in. UseKernelCache flag is yes.  
ATIConfig is yes.  GraphicsEnabler is yes.  It finds fakeSMC, my 
RealTek LAN and posts correctly off Macintosh HD 1 or 2.

Comment 70 by Cosmosis Jones, Aug 3, 2011

so with kernelcache set, the trunk boots lion Raid0 correctly?

Comment 71 by Mark S, Aug 3, 2011

Yes.  Looked like it started working about the time I stated I 
thought I was having a video problem with the Apple ATI card.  It 
was just the fact it was ignoring my /E/E, and I didn't understand 
the way it worked.

Comment 72 by d00d, Aug 3, 2011

mozodojo doesn't have a r1266 branch, although it would be labeled 
r1266 if you did the following;
svn co 
http://forge.voodooprojects.org/svn/chameleon/branches/mozodojo

...instead of;
svn co -r 1233 
http://forge.voodooprojects.org/svn/chameleon/branches/mozodojo

Trunk would be;
svn co http://forge.voodooprojects.org/svn/chameleon/trunk

Would you show the svn command you used?
Thanks.

Comment 73 by Mark S, Aug 3, 2011

I used a app called Versions, and just updated the mozodojo branch.  
Interesting though, it does say r1233.  When I right-clicked it this 
morning and hit 'update' it went to r1266 and displays that at the 
top when I boot.  I used the Chameleon Project file via Xcode to 
compile it.
Starting to sound like I built the trunk somehow.

Comment 74 by d00d, Aug 3, 2011

If you would attach the i386/boot2/boot.c file, that would show if 
mozodojo's fix is being used, thanks.

Comment 75 by Mark S, Aug 3, 2011

Attached.
I rebuilt fresh by opening the mozodojo Xcode project.  I ran thru 
the terminal commands:
bash-3.2# cd ~/Desktop/mozodojo/sym/i386
bash-3.2# sudo fdisk -f boot0 -u -y /dev/rdisk0
bash-3.2# sudo fdisk -f boot0 -u -y /dev/rdisk1
bash-3.2# sudo dd if=boot1h of=/dev/rdisk0s3
2+0 records in
2+0 records out
1024 bytes transferred in 0.000555 secs (1844917 bytes/sec)
bash-3.2# sudo dd if=boot1h of=/dev/rdisk1s3
2+0 records in
2+0 records out
1024 bytes transferred in 0.000330 secs (3103300 bytes/sec)
bash-3.2# diskutil mount disk0s3
Volume Boot OS X on disk0s3 mounted
bash-3.2# cp boot /Volumes/Boot\ OS\ X
bash-3.2# diskutil umount disk0s3
Volume Boot OS X on disk0s3 unmounted
bash-3.2# diskutil mount disk1s3
Volume Boot OSX on disk1s3 mounted
bash-3.2# cp boot /Volumes/Boot\ OS\ X
bash-3.2# diskutil umount disk1s3
Volume Boot OSX on disk1s3 unmounted
Then rebooted.
It states 1266 when I boot.

Comment 76 by Mark S, Aug 3, 2011

ah, there was a Boot OS X in my volumes so the drives were mounted 
as Boot OS X 1.  The copy failed.
So I failed to copy the boot file.  Trying again.

Comment 77 by d00d, Aug 3, 2011

That's mozodojo's r1233 boot.c file, thanks.

Comment 78 by Mark S, Aug 3, 2011

Ok it still said 1266.  I individually removed the boot files from 
both helper partitions and recopied.  Still said 1266. It couldn't 
be using the boot from the Raid Stripe could it?

Comment 79 by d00d, Aug 4, 2011

It uses the boot file located on the first disk listed in the BIOS.

Comment 80 by d00d, Aug 4, 2011

...and it could be labeled v1266, but it's actually v1233, depending 
on how it was checked out or updated.

Comment 81 by Mark S, Aug 4, 2011

k great, it may just be the way this Versions app pulls it.  I see I 
can revert to 1233.  Thanks for being patient and helping me get 
this straight.

Comment 82 by Thom S, Aug 4, 2011

I can confirm that mozodojo's branch works like a charm. Checked on 
a Lion RAID0 install and also on its backup disk (single disk). Used 
"UseKernelCache=Yes", deleted all old Extensions.mkext 
files and also the /E/E folder (previously moved all kext's from 
there to /S/L/E). Also deleted mach_kernel from the Boot helper 
partitions - everything fine (at least for me) - a BIG THANKS for 
this patch!

Although I checked it out from 
http://forge.voodooprojects.org/svn/chameleon/branches/mozodojo my 
chameleon states r1269 - which leaves me a bit puzzled since the 
branch is a 1233 + the patch and nothing more - right?

Comment 83 by d00d, Aug 4, 2011

For it to be labeled correctly you need to check it out with -r like 
I described yesterday.

Comment 84 by Thom S, Aug 4, 2011

Any chance that this will make it into trunk?

Comment 85 by mozo, Aug 6, 2011

I will not add this patch into trunk.

Comment 86 by Cosmosis Jones, Aug 6, 2011

mozodojo:

I am confused. Did you say that when u first merged it to trunk it 
wasn't working, and now it does?

Can you post a diff between current trunk and yours for this patch. 
I"d like to apply it locally and then test it on non soft raid 
on lion.

Thanks
cosmo

Comment 87 by mozo, Aug 6, 2011

Cosmo, first patch was working only for RAID0 partitions because it 
was incomplete.

diff is already here:

http://forge.voodooprojects.org/p/chameleon/source/commit/1233/

p.s. This is small and simple patch, I really don't understand why 
it still not in the trunk. The real problem for me now is kernel 
flag ignorance with latest trunk revisions. After changes in 
chameleon config file (chameleon.plist instead of apple.boot.plist) 
some strange things happen with raid partition. I tested my raid0 
patch on 760 trunk - works like a charm, no problems with config and 
kernel flags readed from boot.plist

Comment 88 by Cosmosis Jones, Aug 6, 2011

merged to trunk.

the boot flag issue is already out there and is being looked at.
Status: Fixed

Comment 89 by Bob Krier, Aug 8, 2011

Hi Everyone,

I've been having problems with Hack/RAID0 as well.  Today I 
downloaded the trunk source from svn.  My setup is textbook like the 
README for Chameleon.  Two soft raids/disk0s3/disk1s3.  I compiled 
and the trunk and installed it just like the README said. 

Now when I boot I always get this error:

"can't find com.apple.boot.S (or P, or R).  If I use 
UseKernelCache=Yes, I get a lot further, but it never gets passed 
the Apple logo and the spinning wheel.  With the -v flag, nothing 
out of the ordinary, it just never starts up?

Anyone have advice?

Thanks

Comment 90 by Mark S, Aug 8, 2011

Bob, sounds like the issue I had. Need to move extra/extensions 
kexts to /s/l/e and rebuild your kernel caches. "sudo touch 
/System/Library/Extensions"

Comment 91 by And G., Aug 8, 2011

Yes, you have to move your /E/E to /S/L/E. Not sure why it won't 
read the kexts from /E/E.

Comment 92 by Bob Krier, Aug 8, 2011

Thanks guys, that did it. :-).  It only works with 
UseKernelCache=Yes.  Good enough for me!!!!

Mucho Gracious!!!

Bob

Comment 93 by Luka Rakamaric, Aug 8, 2011

Hi everyone.

So, what i did so far is follow the guide on insanelymac 
http://www.insanelymac.com/forum/index.php?showtopic=160467 because 
that's how i made it work on snow leopard.
The only difference is i created a raid from four drives, 1+0, two 
mirrors stripped together, but i tried to use only the 'top' raid 
UUID, that seemed logical.

Then i ran into problems as i used the boot file from chimera in 
multibeast 3.8. 

I now see that i have to use the one mentioned here. How do i know 
which one to get, and where, and how do i compile it? I'm 
downloading Xcode as i type this.

How do i rebuild kernel caches, and to which s/l/e do i need to move 
kexts from e/e (i assume since e/e is on the helper partition that 
it should go on the same one?)

I'm not very good at this so if you could explain a little.

Comment 94 by Cosmosis Jones, Aug 8, 2011

Luka. This is NOT THE PLACE for these requests. Post @ 
voodoprojects.org
or insanelymac.

We dont' support CHIMERA either, just trunk.

Comment 95 by Luka Rakamaric, Aug 8, 2011

Sorry, didn't mean to intrude. Anyways, i was able to do it. Got 
1233, placed kexts from E/E to S/L/E, touched SLE, and rebooted, 
that was mostly it. Had to manually enter UseKernelCache.

Comment 96 by Tommy mui, Aug 22, 2011

Yes, the issue is partially fix now.
thanks modojozo, i can now boot without extensions.mkext, but a lot 
of error generate though.
1. my orangeiconfix is not working in S/L/E
2. message like bootcacheoption cannot be found appear
3. kernel keep saying to refuse new kext from loaded when booting

by far, it's good.

Comment 97 by BriLoh, Sep 3, 2011

I honestly have tried pretty much everything to get my RAID to boot, 
no luck.  I've gotten it to boot a couple times and in doing so I 
have added all the kexts from /E/E/ to S/L/E and rebuilt the cache.  
Gave it the restart and it reboots back into the RAID, good times.  
However, out of no where it just hangs at "Waiting for 
DSMOS"  Haven't done anything different, just restarted a 
couple times.  But now, there is just no way into this thing.  I 
have tried the patched Chameleon from this thread and the most 
recent trunk build.  Everything yields the same result.  
"UseKernelCache", normal booting, -x, -v, mixed 
combinations.  Nothing.

Created: 8 years 13 days ago by Tommy mui

Updated: 7 years 10 months ago

Status: Fixed

Owner: Cosmosis Jones

Followed by: 14 persons

Labels:
Priority:Medium
Type:Defect
Target:2.0