Chameleon

Issue 231: @meklort

Reported by Cyrus The Great, Mar 9, 2012

hi meklort
it seems that you delete your branche permanently .
but i use the your kernel patcher test version for cpus=1 problem in 
hp bios its work great with some debuge information.but 
unfurtunantly i miss this test version becuase of bad sector of hard 
disk.plz can you post it again or add the kernel patcher to 
chameleon.
thanks

Comment 1 by Peter _sm, Mar 10, 2012

This would be perfect if we could have this patch, what is the 
command ? or is it patching without any parameters?

Looking forward to see this patch in chameleon ;-)

Comment 2 by Daniel Lanz, Mar 10, 2012

Hey Cyrus!

I found that:

http://forge.voodooprojects.org/p/chameleon/source/tree/158/branches/
meklort

I hope it helps.

Cheers.

Comment 3 by Cyrus The Great, Mar 10, 2012

its kernel patcher modules peter_sm.
thanks daniel lanz but the problem is here :
meklort never release this patch to public.
there kernel patcher in cparm branch that work in snow but with lion 
the address has been changed and patcher not work it need to be 
updated .

Comment 4 by Flashe, Mar 10, 2012

Hi everyone,
I can make testes if you want.Me too i have this problem with a 
laptop HP DV7 i7 2630QM(Intel HD3000)/AMD HD 6770M boot only with 
flag cpus=1 and busratio=20 if a patch included directly in 
chaméléon is good work for us community hack,because many people 
have this problem.Send me the files for the testes.

Thanks

Comment 5 by Peter _sm, Mar 10, 2012

I have a HP DV8t-1290e0 (WN916EA#UUW) | 1.60 GHz Intel Core i7-720QM 


Would be nice to see if someone could look at this patch.

So If this is done, I need to load this module during boot?

Comment 6 by Cyrus The Great, Mar 10, 2012

@peter_sm
its load automatically and patch the kernel in the fly .
like resolution or other module.

Comment 7 by Daniel Lanz, Apr 21, 2012

@ Cyrus

Have you seen that? Somebody posted the lapic patch modules for 10.6 
over at OSX86.net:

http://www.osx86.net/view/2616-modules_lapic_patch.html

This could be a starting point.

Comment 8 by Cosmosis Jones, May 4, 2012

Status: Invalid

Created: 6 years 3 months ago by Cyrus The Great

Updated: 6 years 1 month ago

Status: Invalid

Followed by: 4 persons

Labels:
Priority:Medium
Type:Defect