Chameleon

Issue 253: Please add memory to system profiler on Vaio VPCEH2m0E please!!!

Reported by shulillo vedder, May 9, 2012

Please add memory to system profiler on Vaio VPCEH2m0E please!!! and 
fix "about this mac crashes"

Comment 1 by Evan Lojewski, May 9, 2012

You're going to have to give a lot more information that that.

For example, what's the output of bdmesg, what;s in the ioreg. What 
is currently happening (crash report?).
Status: AwaitingInformation

Comment 2 by shulillo vedder, May 9, 2012

ok, I have no problem with that. What are the steps I have to 
continue to give you the necessary information? I do not know what 
it is bdmesg. 
The crash report is that i click on about this mac , and craches, 
the dock and finder reboot and the screen goes black for a moment.
in the system profiler app , doesn´t show the memory information but 
any apps detects 4 gb ram.
sorry if my english is bad. i am from spain.

Comment 3 by shulillo vedder, May 9, 2012

well. chameleon detects the memory Ram , but Lion doesn´t detect. i 
have read that smbiosefi.kext resolves it, but doesnt it.

Comment 4 by Cosmosis Jones, May 9, 2012

bdmesg

it is a separate file packaged in the chameleon downloads.
i'll attach it here.

in terminal do

sudo cp bdmesg /usr/sbin/

then type
bdmesg

Comment 5 by Cosmosis Jones, May 9, 2012

you may also need to do
sudo chmod +x /usr/sbin/bdmesg

Comment 6 by shulillo vedder, May 9, 2012

ok, thanks!.
Here is the result:
bash-3.2# bdmesg
Enoch by ErmaC (r1943) [2012-05-08 12:48:11]
cpu freq classic = 0x000000008eba620a
msr(385): platform_info 60011800
msr(389): flex_ratio 0001ff00
Sticking with [BCLK: 99Mhz, Bus-Ratio: 240]
CPU: Brand String:             Intel(R) Core(TM) i5-2430M CPU @ 
2.40GHz
CPU: Vendor/Family/ExtFamily:  0x756e6547/0x6/0x0
CPU: Model/ExtModel/Stepping:  0x2a/0x2/0x7
CPU: MaxCoef/CurrCoef:         0x0/0x18
CPU: MaxDiv/CurrDiv:           0x0/0x0
CPU: TSCFreq:                  2394MHz
CPU: FSBFreq:                  100MHz
CPU: CPUFreq:                  2394MHz
CPU: NoCores/NoThreads:        2/4
CPU: Features:                 0x000002ff
Attempting to read GPT
Read GPT
Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B
Reading GPT partition 2, type 48465300-0000-11AA-AA11-00306543ECAC
Reading GPT partition 3, type EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
Reading GPT partition 4, type 48465300-0000-11AA-AA11-00306543ECAC
Reading GPT partition 5, type 48465300-0000-11AA-AA11-00306543ECAC
Read HFS+ file: 
[hd(0,5)/System/Library/CoreServices/SystemVersion.plist] 476 bytes.
Read HFS+ file: 
[hd(0,2)/System/Library/CoreServices/SystemVersion.plist] 476 bytes.
Read HFS+ file: [hd(0,2)/Extra/org.chameleon.Boot.plist] 923 bytes.
Module 'Symbols.dylib' by 'Chameleon' Loaded.
	Description: Chameleon symbols for linking
	Version: 0
	Compat:  0
Read HFS+ file: [hd(0,2)/Extra/modules/Keylayout.dylib] 13424 bytes.
Module 'Keylayout.dylib' by 'Unknown' Loaded.
	Description: 
	Version: 0
	Compat:  0
Read HFS+ file: [hd(0,2)/Extra/Keymaps/mac-es.lyt] 464 bytes.
Read HFS+ file: [hd(0,2)/Extra/modules/klibc.dylib] 44252 bytes.
Module 'klibc.dylib' by 'Unknown' Loaded.
	Description: 
	Version: 0
	Compat:  0
Read HFS+ file: [hd(0,2)/Extra/modules/Resolution.dylib] 22428 
bytes.
Module 'Resolution.dylib' by 'Unknown' Loaded.
	Description: 
	Version: 0
	Compat:  0
Buffer location: 0x1000F8CA status: 1
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
getResolution: 2124x65534x32
Buffer location: 0x1000F7EA status: 1
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00 
0x00 0x00 0x00 
Read HFS+ file: [hd(0,2)/Extra/modules/uClibcxx.dylib] 77808 bytes.
Module 'uClibcxx.dylib' by 'Unknown' Loaded.
	Description: 
	Version: 0
	Compat:  0
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/theme.plist] 2785 
bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/background.png] 
2266296 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/logo.png] 2951 
bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_generic.png] 12734 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_generic_o.png] 14728 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_hfsplus.png] 18171 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_hfsplus_o.png] 20025 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_hfsraid.png] 18089 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_hfsraid_o.png] 19933 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_ext3.png] 
15983 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_ext3_o.png] 
18069 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_fat.png] 
12998 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_fat_o.png] 
15003 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_ntfs.png] 
16871 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_ntfs_o.png] 
19072 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/device_cdrom.png] 
13271 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_cdrom_o.png] 15351 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_selection.png] 1435 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_scroll_prev.png] 2008 
bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/device_scroll_next.png] 2020 
bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/menu_boot.png] 
1975 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/menu_verbose.png] 
2155 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_ignore_caches.png] 2121 
bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_single_user.png] 2228 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_memory_info.png] 1486 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_video_info.png] 1550 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/menu_help.png] 
2178 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_verbose_disabled.png] 2080 
bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_ignore_caches_disabled.png] 
2029 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_single_user_disabled.png] 
2159 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/menu_selection.png] 418 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/progress_bar.png] 
1037 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/progress_bar_background.png] 1034 
bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/text_scroll_prev.png] 791 bytes.
Read HFS+ file: 
[hd(0,2)/Extra/Themes/LoginToLion/text_scroll_next.png] 798 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/font_console.png] 
11752 bytes.
Read HFS+ file: [hd(0,2)/Extra/Themes/LoginToLion/font_small.png] 
9634 bytes.
Read HFS+ file: 
[hd(0,2)/Library/Preferences/SystemConfiguration/com.apple.Boot.plist
] 71 bytes.
Read HFS+ file: [hd(0,2)/Extra/org.chameleon.Boot.plist] 923 bytes.
Loading Darwin 10.8
Loading kernel cache 
/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
Read HFS+ file: 
[hd(0,2)/System/Library/Caches/com.apple.kext.caches/Startup/kernelca
che] 4096 bytes.
Read HFS+ file: 
[hd(0,2)/System/Library/Caches/com.apple.kext.caches/Startup/kernelca
che] 19048044 bytes.
Read HFS+ file: [hd(0,2)/Extra/dsdt.aml] 34087 bytes.
Using PCI-Root-UID value: 0
GeForce 410M 1024MB NVd9 [10de:1055]-[104d:908b] :: 
PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0) device number: 1
dcb table at offset 0x51b0
LAN Controller [10ec:8168] :: 
PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)
Setting up lan keys
Read HFS+ file: [hd(0,2)/Extra/smbios.plist] 699 bytes.
SMBus CmdReg: 0x3
Scanning SMBus [8086:1c22], mmio: 0xd5305004, ioport: 0x5000, hostc: 
0x1
SPD[0] (size): 146 @0x50
Slot: 0 Type 24 4096MB (DDR3 SDRAM) 20307MHz Vendor=Elpida
      PartNo=EBJ41UF8BCS0-DJ-F0 SerialNo=5A2E12CC
SPD[0] (size): 255 @0x51
SPD[0] (size): 255 @0x52
SPD[0] (size): 255 @0x53
SPD[0] (size): 255 @0x54
SPD[0] (size): 255 @0x55
SPD[0] (size): 255 @0x56
SPD[0] (size): 255 @0x57
CPU is Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz, family 0x6, model 
0x2a

Type: 0, Length: 24, Handle: 0x0
BIOSInformation:
	vendor: Apple Inc.
	version: MBP81.88Z.0047.B0E.1104221557
	releaseDate: 04/22/11

Type: 1, Length: 27, Handle: 0x1
SystemInformation:
	manufacturer: Apple Inc.
	productName: MacBookPro8,1
	version: 1.0
	serialNumber: C02H7745DH2G
	uuid: 80B8FA06-C1DD-DE11-8078-78843CF1E15E
	wakeupReason: 0x6
	skuNumber: N/A
	family: MacBook Pro

Type: 2, Length: 10, Handle: 0x2
BaseBoard:
	manufacturer: Apple Inc.
	product: Mac-94245B3640C91C81
	version: N/A
	serialNumber: N/A
	assetTagNumber: N/A
	locationInChassis: 
	boardType: 0x6C

Type: 3, Length: 17, Handle: 0x3
SystemEnclosure:
	manufacturer: Sony Corporation
	type: 10
	version: N/A
	serialNumber: N/A
	assetTagNumber: N/A

Type: 11, Length: 5, Handle: 0x4
Type: 32, Length: 20, Handle: 0x5
Type: 136, Length: 6, Handle: 0x6
Type: 16, Length: 15, Handle: 0x7
Type: 17, Length: 21, Handle: 0x8
MemoryDevice:
	deviceLocator: SODIMM1
	bankLocator: Bank 0
	memoryType: DDR3
Type: 20, Length: 19, Handle: 0x9
Type: 17, Length: 21, Handle: 0xa
MemoryDevice:
	deviceLocator: SODIMM2
	bankLocator: Bank 1
	memoryType: RAM
Type: 19, Length: 15, Handle: 0xb
Type: 4, Length: 35, Handle: 0xc
ProcessorInformation:
	socketDesignation: N/A
	processorType: 3
	processorFamily: 0xCD
	manufacturer: GenuineIntel
	processorID: 0x206A7
	processorVersion: Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz
	externalClock: 0MHz
	maximumClock: 2394MHz
	currentClock: 2400MHz
	serialNumber: N/A
	assetTag: N/A
	partNumber: N/A

Type: 7, Length: 19, Handle: 0xd
Type: 7, Length: 19, Handle: 0xe
Type: 7, Length: 19, Handle: 0xf
Type: 131, Length: 6, Handle: 0xf
AppleProcessorType:
	ProcessorType: 0x601

Type: 132, Length: 6, Handle: 0x10
AppleProcessorBusSpeed:
	ProcessorBusSpeed (QPI): 0.1GT/s

Type: 127, Length: 4, Handle: 0x11

Customizing SystemID with : 80b8fa06-c1dd-de11-8078-78843cf1e15e
Read HFS+ file: [hd(0,2)/Extra/dsdt.aml] 34087 bytes.
ACPI table not found: SSDT.aml
FADT: Restart Fix applied!
FADT: Using custom DSDT!
Found ACPI CPU: CPU0
Found ACPI CPU: CPU1
Found ACPI CPU: CPU2
Found ACPI CPU: CPU3
Found ACPI CPU: CPU4
Found ACPI CPU: CPU5
Found ACPI CPU: CPU6
Found ACPI CPU: CPU7
SSDT with CPU C-States generated successfully
P-States: min 0x8, max 0x18
SSDT with CPU P-States generated successfully
RSDT: Added 2 SSDT table(s)
FADT: Restart Fix applied!
FADT: Using custom DSDT!
Added 2 SSDT table(s) into XSDT
Errors encountered while starting up the computer.
Pausing 5 seconds...
Starting Darwin x86_64
Boot Args: boot-uuid=1C635FB9-DAB6-3BE6-B5E2-7E81AF56B87C rd=*uuid 
darkwake=0

Comment 7 by shulillo vedder, May 9, 2012

I am using Mountain Lion DP2, but en Lion 10.7.3 also fails.
in smbios.plist add the Ram memory data, but doesn´t show.
i add a photo.

Comment 8 by shulillo vedder, May 9, 2012

iF i delete the applesmbios.kext, the about this mac works fine but 
doesn´t show de memory and the boot is very slow!

Comment 9 by shulillo vedder, May 9, 2012

its the video where shows the crash

Comment 10 by Cosmosis Jones, May 10, 2012

You are using mountain lion and ermacs branch.
please work with him otherwise ermac you can close this
Owner: ifabio

Comment 11 by shulillo vedder, May 10, 2012

and i dont have fix for my vaio laptoc?

Comment 12 by ErmaC , May 10, 2012

shulillo vedder.
Try replace my version with the main trunk revision of chameleon, 
now also support Mountain Lion..
and we see if the error still here.

Fabio (ErmaC)

Comment 13 by shulillo vedder, May 11, 2012

i have installed Iatkos l2 and still doesn´t show the memory. I have 
the new chameleon 1969

Comment 14 by ErmaC , May 11, 2012

So isn't an issue relate to Chameleon or his branches.
(for what I understand), and as you specify is not only related to 
Mountain Lion but also happened in Lion.

So the problem is elsewhere.

Fabio (ErmaC)
Status: Invalid

Created: 6 years 17 days ago by shulillo vedder

Updated: 6 years 15 days ago

Status: Invalid

Owner: ErmaC

Followed by: 2 persons

Labels:
Priority:Medium
Type:Defect