Chameleon

Issue 255: DualLink in Intel HD3000, blackscreen problem

Reported by idd pioneer, May 16, 2012

The problem ocurrs when you try to boot at a resolution higher than 
1280x768 using a Intel HD3000, you will have a blackscreen when you 
get to the desktop of OSX.

Searching in the sources I found in gma.c at the section "Intel 
HD Graphics 3000 Mobile"
you will find this line:
devprop_add_value(device, "AAPL00,DualLink", 
HD3000_vals[10], 4);
I can say that the problem is here, because I have to add this 
property to my dsdt to solve the black screen problem.
You can try it in any Intel HD Graphics Card, I think this issue 
includes the HD2000. But I have no one to test.

Comment 1 by idd pioneer, May 16, 2012

adding more info:
My dsdt:

                    "AAPL00,DualLink", 
                    Buffer (0x04)
                    {
                        0x01, 0x00, 0x00, 0x00
                    }
with this it works very well with any resolution, I tested until 
1920x1080 because is the maximum that the screen of my notebook 
supports.

Comment 2 by Cosmosis Jones, May 16, 2012

if you actually look at gma.c on the trunk you'll notice that there 
is a big if/else if section based on the model name

what model name are you using???.. cause some model names don't 
inject that value.

you may want to remove that dsdt patch, boot up at your lower 
resoluation, and provide a bdmesg and ioreg.
Status: AwaitingInformation

Comment 3 by idd pioneer, May 16, 2012

I did not use any model name, because my intel uses the ID 0126 its 
the native id of my HD3000.

Ok I will do the thing you asked for.

Comment 4 by idd pioneer, May 17, 2012

I tryed it but even in 800x600 it stays black ...
What can I do ?

it only becomes normal when I return the DualLink in the dsdt.

Comment 5 by idd pioneer, May 17, 2012

The thing is if the chameleon injects the properties, then it should 
be there and I dont need to add it to the dsdt.

I think right ?

Comment 6 by Cosmosis Jones, May 20, 2012

did you remove the dsdt, boot up, and post a bdmesg and ioreg like i 
asked?

Comment 7 by Cosmosis Jones, Oct 29, 2012

No Response
Status: Invalid

Created: 2 years 2 months ago by idd pioneer

Updated: 1 year 8 months ago

Status: Invalid

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect