Chameleon

Issue 48: GTX-580 Error - bad display config block signature (0xff45dfff)

Reported by rabbit 74, Dec 3, 2010

I am trying to help a guy with his new GTX-580 over on the Tonymac 
forum. He is getting the following error on boot:
-------------------------------------------------
bad display config block signature (0xff45dfff)
ERROR: nVidia ROM Patching Failed!
-------------------------------------------------

So far he has gotten the driver installed on 10.6.5 and tried both 
your boot and RC5 but using either results in booting to Low 
Graphics mode.

Any thoughts? I have not seen that error so I don't know what to 
suggest at this point.

rabbit.

ref: http://www.tonymacx86.com/viewtopic.php?f=...60&start=10

Comment 1 by Philippe Perrot, Dec 7, 2010

I get the same error on my system.

Comment 2 by Philippe Perrot, Dec 7, 2010

Using aquamac bug fixes, the error disappear, but the card doesn't 
work properly

Comment 3 by Engelbert Gal, Dec 10, 2010

The same error appears on a PNY GTX 460 (VCGBTX4601XPB) 


http://www.tonymacx86.com/viewtopic.php?f=15&t=8625

Comment 4 by Cosmosis Jones, Jun 2, 2011

if this is still a problem reopen referencing TRUNK
Status: Invalid

Comment 5 by Philippe Perrot, Jun 3, 2011

Hi, this issue is still existing under 10.6.7

Comment 6 by Cosmosis Jones, Jun 3, 2011

Status: Accepted

Comment 7 by Cosmosis Jones, Jun 3, 2011

yeah not 10.6.7 as much as are u using a boot compiled from the 
trunk?

rev(944)

Comment 8 by Philippe Perrot, Jun 3, 2011

Yes, I got this issue in using this nvidia card with ATI 5680.

Comment 9 by Cosmosis Jones, Jun 3, 2011

Ah ok then.. you have 2 cards, so the graphics patcher said bad 
config for the ATI.. How exactly is everything setup (ie which slot 
is primary/which secondary)

Comment 10 by Philippe Perrot, Jun 3, 2011

The ati is primary and I get this message with the nvidia, in 
second. The graphic patcher said bad config for nvidia, and is fine 
for Ati

Comment 11 by Philippe Perrot, Jun 3, 2011

The ati is primary and I get this message with the nvidia, in 
second. The graphic patcher said bad config for nvidia, and is fine 
for Ati

Comment 12 by Pedro A. Aranda, Jul 3, 2011

"Coming from issue 96" and just arrived. Hi :-) Well my 
laptop is one those NVidia Optimus things with dual GPU. The NVidia 
on PCI 1 and I have an Arrandale IntelHD on PCI0. 

In my case, I see that the NVidia Patcher says it can't patch my 
graphics card and I have '-4095 MBytes of video RAM' It also says 
other things, but it goes a bit too fast for me. Can I stop 
Chameleon somehow to get the rest of the messages?

Thanks a lot /PA

Comment 13 by Pedro A. Aranda, Jul 3, 2011

BTW, I forgot:

I have a 1366x768 13 inch laptop (ASUS U30Jc) and I don't get beyond 
1024x768. I'm using Chameleon-2.0-RC5-r1083 from olarila.com

http://olarila.com/forum/viewtopic.php?f=9&t=70

Thanks /PA

Comment 14 by Azimutz, Jul 16, 2011

Hi guys...

this is not very important for this issue but, i noticed no one 
cared about posting concrete info about the cards, e.g. model, 
device id, subsys id an vendor.
Not good!

About the issue, two things:
- i have added pauses on the messages related to the issue (r1164) 
to help you guys in collecting feedback; please try the booter again 
and feedback

- i followed the link on comment #3 and read some interesting stuff 
about this problem, when dual booting with Windows; anyone can 
check/confirm it?

I have suspicions but i can't test nVidia atm and without proper 
feedback we can't fix any. So, remember the cards info...
If there's no feedback soon i'll end up closing the issue!

Thanks

Comment 15 by Philippe Perrot, Jul 16, 2011

Hi,
got this trouble with Sapphire ati 5870 and evga gtx 580, under osx 
10.6.6, and the nvidia board was the second board to get this 
message ; got this message with gtx285 as second board. Mother board 
is evga SR-2. The booter was r470. Won't able to test anything until 
august or october, as  I'll be back home.
Regards

Comment 16 by Azimutz, Jul 17, 2011

Hi Philippe...
that doesn't help much. Test again when you can.
If the issue is closed create a new one.

Thanks

Comment 17 by Pedro A. Aranda, Jul 17, 2011

Hi

Before going to the new bootloader, just another thing I have seen:

Chameleon is not able to find any 1366x768 VESA mode on my machine...

Comment 18 by Azimutz, Jul 17, 2011

Pedro, that's not a Chameleon problem; your card's rom simply 
doesn't have that vesa mode; to confirm, when you are at the boot 
prompt, hit the "down arrow" key and select "Video 
info"; it will show you the available modes.

The booter it's not new; i just added some pauses so you guys are 
alerted to the problem and can note down the error messages in case 
you can't boot. If you still can boot, the error messages can be 
checked on the boot log (bdmesg).

Comment 19 by Philippe Perrot, Jul 17, 2011

What will help much ? What do you need ?
Regards

Comment 20 by Azimutz, Jul 18, 2011

Philippe, read comment 14 carefully; it's all there!!
Just ignore the "pauses" added stuff; i removed them 
because you guys can check the messages on the boot log (bdmesg). 
Look for these:

- no dcb table found
- Bad display config block signature...
- Bad Display Configuration Block signature...
- ERROR: dcbtable_version is...

Any of these messages will also print:

- ERROR: nVidia ROM Patching Failed!

Comment 21 by Cosmosis Jones, Jul 18, 2011

Labels: Target:2.1
Owner: azimutz

Comment 22 by Cosmosis Jones, Jul 18, 2011

Labels: Target:2.0 Target:2.1

Comment 23 by Philippe Perrot, Jul 19, 2011

Is this pict helpful ?
Best regards

Comment 24 by Evan Lojewski, Jul 20, 2011

Azimutz: I was taking a look at the nvclock source code and found 
this for reading the vbios from the NV50 family of cards:


	/* On NV5x cards we need to let pramin point to the bios */
	if (nv_card->arch & NV5X)
	{
		uint32_t vbios_vram = (nv_card->PDISPLAY[0x9f04/4] & ~0xff) 
<< 8;

		if (!vbios_vram)
			vbios_vram = (nv_card->PMC[0x1700/4] << 16) + 0xf0000;

		old_bar0_pramin = nv_card->PMC[0x1700/4];
		nv_card->PMC[0x1700/4] = (vbios_vram >> 16);
	}

We currently are not doing this with the NV50 cards, so this change 
(or equiv) may be needed. I don't have a NV50 card, so I cannot test 
this.

Comment 25 by Pedro A. Aranda, Jul 22, 2011

I collected a couple of things, both Linux and MacOS from my Asus 
U30Jc. I have also tried to get the NVidia ROM with FreeDOS + 
NVFlash but it says EEPROM not recognised...

I have edited the Linux DMESG output because of its length. I just 
hope I didn't delete anything important. Anyhow, I have a backup :-)

Comment 26 by Azimutz, Jul 23, 2011

Hi guys; i've been without network for last couple of days so, i 
need some time to get back on top of stuff...

Philippe, the pic is a start, yes :)

Pedro, will take a look.

Evan, yep...
i suspect of at least two things for now:
- windows may be setting something on the card that causes the bad 
config diplay, when booting OS X by rebooting directly from windows
- we need to update the code for new cards, like you suggest

For now, i can't test nVidia; i have the GT 220 to install on the 
desktop, but i need the only available pci express slot for ATi 
testing; the laptop has a GT 450M, but it will take a while for me 
to get my hands on it. Besides, i never used nVidia so, the 
knowledge is very limited.. keep that in mind ;)

Comment 27 by Philippe Perrot, Jul 23, 2011

yes, it's an old pict of start, took in february. As I'll be able to 
access to my computer, I'll wil test with last booter and lion... 
But I think the trouble remains. I done some test with lion in may, 
it was stopped by new "pci config" stuff. I've read the 
solution to pass through this trouble in adding something in 
boot.plis file.

Comment 28 by Cosmosis Jones, Jul 25, 2011

Labels: Target:2.1 Target:2.0

Comment 29 by A Sto, Sep 7, 2011

I'm experiencing the same issue. The computer boots to Lion fine 
unless there is a power outage or booted from Windows prior.

 The only way I have been able to fix this is to take the GTX 580 
out of the computer and leave it overnight. The next reboot after 
the GTX580 boots chameleon as expected.

I have a Gainward GTX 580 3GB Phantom.

Comment 30 by Locmer -, Oct 22, 2011

Trying to add a:

Gainward GeForce (512 MB) (4718462009726) Graphics Card

to a 10.7.2 on a Gigabyte GA-Z68X-UD3H-B3

Results in:

ERROR: dcbtable_version is 0x3
ERROR: nVidia ROM Patching Failed!

for details of how Mac OS X sees the GEForce 8400 see attached jpeg

Comment 31 by Moik The, Apr 25, 2012

Howdi! 

Not sure if this is still an issue, but here's my solution to it ;)

Actually I stumbled upon the very same issue and tried to find out 
what's wrong. When comparing the current nvidia injector code with 
the nouveau codebase (especially the dcb reading part) reading 
multibyte integers need to be swapped on some cases. 

In this patch I change the following:
- some of the uint16 and uint32 reading issues
- swapped the order of rom fetching from pramin-prom to prom-pramin 
(guess that's just a matter of taste)

I just fixed the necessities as currently I'm in the process of 
rewriting the entire nvidia injector from the scratch based on 
information from the current nouveau codebase. Will share my 
progress in case anyone is still interested in having most of the 
nvidia issues resolved ;)

Comment 32 by Philippe Perrot, Apr 25, 2012

Hi Michael,
I'm still interested by solving this issue.
Thanx

Comment 33 by Cosmosis Jones, Apr 25, 2012

submit your patch as a patch on forge.
also join irc and #Chameleon

message me to get invited into the dev channel if you are going to 
rewrite it

thanks
cosmo1t

Comment 34 by Cosmosis Jones, May 8, 2012

merged patch (some of it)
restructured some things on my own as well
Status: Fixed
Owner: cosmo1t

Comment 35 by bu11etpr00f, Aug 21, 2012

It appears that this issue might be related to using dual video 
cards (one ATI & one NVIDIA).

All my details are included in my post here: 
http://www.tonymacx86.com/graphics/68171-dual-graphics-video-cards-at
i-radeon-5770-nvidia-geforce-8800-gt-trinary-3-three-displays.html

Thanks!

Comment 36 by Anmol Mishra, Nov 10, 2012

This issue is still a problem, and there are many posts regarding 
this. 

bu11etpr00f has given an excellent summary in his post above.

Comment 37 by Cosmosis Jones, Nov 11, 2012

thats nice. dual video card issue IS not the same as bad block sig. 
Chameleon has never supported injecting multiple video cards from 
different manufactures on the same GE=yes flag. Maybe it was 
intended to do so , but never worked. Instead of continuing to pile 
crap on this post, open a new one with an appropriate title and 
information. Nothing is more annoying than reading new posts on 
closed tickets. This is an issue in our ticketing system that i am 
going to get fixed.

So open a new issue, with the real information, the real bdmesg's 
outputs, multiple dev ids, the ioregs, etc, not a link to another 
forum  site. 

mmmmmk?

Created: 8 years 10 months ago by rabbit 74

Updated: 6 years 11 months ago

Status: Fixed

Owner: Cosmosis Jones

Followed by: 11 persons

Labels:
Priority:Medium
Type:Defect
Target:2.1