Chameleon

Issue 125: usekernelcache not working in 1203

Reported by Cyrus The Great, Jul 23, 2011

Steps to reproduce the problem:
1.i am download the latest chameleon from build bot and installed it
2.set UseKernelCache=Yes
3.restart and seen that the boot loader docent load next from 
cache.its load all of kext like -f option every time i am booting

Expected result:load kext from kernel cahche 

Actual result:it load all of the kexts like -f option or i must 
create Extensions.mkext to load from it

Comment 1 by Jim McDowell, Jul 28, 2011

Just curious, if you delete the kernel cache and reboot, does it 
work the first time? I'm encountering the same problem with 
extensions.mkext. I've also been reading other users who are seeing 
the same issue, but thought it was raid related.

Comment 2 by Cyrus The Great, Jul 28, 2011

i am currently back to chameleon r1156 and its load kernel cache .i 
not using extension.mkext  because using kernel chache boot faster 
and without error.i dont know whats this disabled in current realse 
of chameleon.

Comment 3 by Cosmosis Jones, Jul 28, 2011

Labels: Target:2.0
Status: Accepted
Owner: meklort

Comment 4 by Cosmosis Jones, Aug 2, 2011

Can you please try the latest rev from the trunk and let us know
thanks

Comment 5 by Cyrus The Great, Aug 2, 2011

sorry the problem is not with chameleon i found the source of 
problem .kernelcache only work in vanilla kernel .
the compiled one from source can not load the kernel cache.
the UseKernelCache flag work fine with vanilla kernel

Comment 6 by Evan Lojewski, Aug 2, 2011

Status: Invalid

Created: 7 years 11 months ago by Cyrus The Great

Updated: 7 years 11 months ago

Status: Invalid

Owner: Evan Lojewski

Followed by: 2 persons

Labels:
Priority:Medium
Type:Defect
Target:2.0