Chameleon

Issue 195: 6990m issue---ATI.C

Reported by Applehacker, Oct 25, 2011

Compiled latest chameleon, checked ATI.c file
6900m series listed with framebuffer kNull

bootloader states card is unsupported w/ GraphicsEnabler=Yes

GraphicsEnabler=No allows system to boot, full resolution 
(1920x1080), but screen is fuzzy, colors are messed up.
GREP ATY states generic RadeonFramebuffer is in use

Using any 6xxx framebuffer such as duckweed or elodea gives black 
screen----> possible ports configuration wrong?

Close to working
Dev: 0x6720
Vend: 0x1002
Subsys: 0x04BA1028


Recommended framebuffer: elodea (as per Imac 2011)

looking forward to comments.

Comment 1 by Cosmosis Jones, Nov 3, 2011

so when you do AtiConfig=ELODEA
it still doesn't work?

Comment 2 by Applehacker, Nov 9, 2011

It still doesn't work. I get a quick grey flash, then a black 
screen. I think it may have something to do with port 
detection......I am not sure. I need dev input here.

Comment 3 by Cosmosis Jones, Nov 9, 2011

post a bdmesg as well please

Comment 4 by Applehacker, Nov 9, 2011

How? I have no video access in OS X through the 6990m... but i do in 
the Intel 3000 gfx......can I just bdmesg from there?

Comment 5 by Cosmosis Jones, Nov 9, 2011

can u boot -s, ge=no

Comment 6 by Applehacker, Nov 9, 2011

I booted with both IGP and ATI enabled, by default it uses IGP, so I 
ran BDMESG. log attached below:

Comment 7 by Applehacker, Nov 29, 2011

No developments Cosmosis Jones?

Comment 8 by Cosmosis Jones, Nov 30, 2011

sorry nope, i'd need a boot of just the ati and not on the igp.

but 6990 in general isn't supported via the ati6000 controller. Some 
have gotten it working.

I dont' know if the 6990m is a totally different beast or not.. but 
you'd have to boot into -s using the 6990 and not the IGP to get teh 
correct bdmesg

Comment 9 by Applehacker, Nov 30, 2011

Ok I will be getting you one immediately in just ATI mode. Just to 
clarify some things:

1.This is a MOBILITY 6990, not a desktop 6990. The cores are 
different. The Mobility 6990 is like a desktop 6850/6870

2. The device ID's for 6970m and 6990m ARE EXACTLY the same. Thus, 
theoretical support should exist natively in ati6000controller. I 
have seen the device ids myself in there. The 6970m is in the 
current imac, the 6990m is not. however, both cards are the same dev 
and vendor ids. 

again, I will get you an ATI-Only bdmesg ASAP.

Comment 10 by Applehacker, Dec 18, 2011

OK. I managed to get a BDMESG of just my ATI card, with 
graphicsEnabler=no
Attached below. please advise.

Comment 11 by Applehacker, Jan 3, 2012

Any update Cosmosis Jones, since I uploaded the new BDMESG?

Comment 12 by Marco Masselli, Jan 13, 2012

If using the intel, probably the problem is this 
http://www.tonymacx86.com/viewtopic.php?f=15&t=28851 Try to 
patch it as it state.

Carefull. if you have already that method, you need to change it and 
update it.

Comment 13 by Flashe, Feb 21, 2012

Hi everyone,
@Cosmosis Jones 
Possible add in chameleon 2 cards ?
Only chimera 1,7 detected out of box the 2 cards same time

Video Card : Intel(R) HD3000 Mobile Dev ID 0116: Ven ID 8086, Ati 
HD6770m 2GB Gddr5 Dev ID 6740:Ven ID 1002.

Because now impossible update bootloader,use the old version of 
chimera 1,7 1459. 
Other problem for me 17 inch screen boot chameleon résolution is bad 
:1024*768 the résolution correct is 1600*900 this problem is 
bootloader ? Possible resolved this problems ?

Comment 14 by Cosmosis Jones, Feb 21, 2012

So the dsdt patch just adds the 
                        "AAPL00,DualLink", 
..

gma.c could include ..

but the issue still is 2 cards booting.. 

thats why the dsdt patch works, but chameleon won't..
i think netkas got something working by trying to do this:

in chameleon use graphics enabler for intel. set intel as boot 
display.
use AtiROM for the ati card..

i dunno

Comment 15 by Applehacker, Feb 22, 2012

Ok I post the full results of my experiment:

ATI GPU only results in only black screen, regardless of ATI.rom or 
ge=yes. Something is wrong with the way the LVDS is encoded in the 
ATI6000Controller.kext I don't think chameleon will be able to solve 
this, only a DSDT to kext mod will do it.

Intel IGP works with GE so long as we have dual-link patch in the 
DSDT. 


This is an LVDS issue i'm pretty sure. If I hook up my HDMI in to my 
HDMI out, we get a display on the laptop screen. Something is not 
sending properly to LVDS. Any more ideas?

Comment 16 by Cosmosis Jones, Feb 22, 2012

well open a new issue w/ the intel IGP for adding that dual link.

dual link is added for device x3100

what is the device id pci id/  venid for yours.

we need to add that to gma.c but that isn't part of this issue.

Comment 17 by Applehacker, Feb 22, 2012

This thread is for 6970m/6990m only. IGP is easily fixed, just add 
dual link patch.... its literally copy and paste. Any thoughts on 
6970m/6990m?

Comment 18 by Flashe, Feb 22, 2012

Ok,
But new version chameleon detected intel hd 3000 "intel 
unknown"i boot with graphicsenabler=yes i assume the DevID and 
VenID not insert totally in chameleon.
Possible insert Definetely the DevID and VenID of the 2 cards please 
?
HD3000 Mobile Dev ID 0116: Ven ID 8086
HD6770m Dev ID 6740:Ven ID 1002.


Thanks advance Cosmosis.

Comment 19 by Applehacker, Feb 22, 2012

Intel is auto detected...... as of version 1.6, so I have no idea 
what you are talking about. I get Intel HD 3000 when using chimera 
1.7, so unless you have weird dev ids, it should definitely work for 
your, or your BIOS settings are wonky.

Comment 20 by Luca Grandi, Mar 16, 2012

Can someone try this?
{ 0x6720,	0x51041558, CHIP_FAMILY_BARTS,		"AMD Radeon HD 
6990M",	kElodea	},

Comment 21 by Cosmosis Jones, May 5, 2012

Status: Fixed

Comment 22 by Applehacker, May 11, 2012

What fix was applied, and where can we download the fixed bootloader?

Comment 23 by Cosmosis Jones, May 11, 2012

i just added that dev id above.
anyway, i wont' respond on this issue anymore.. too much cross crap 
in it.

Created: 7 years 24 days ago by Applehacker

Updated: 6 years 6 months ago

Status: Fixed

Followed by: 4 persons

Labels:
Priority:Medium
Type:Defect