Chameleon

Issue 243: Could you add support for Gigabyte Radeon HD5570?

Reported by Piotr Kasperczyk, Apr 16, 2012

ATOM BIOS Rom: 
	SubsystemVendorID: 0x1458 SubsystemID: 0x254b
	IOBaseAddress: 0x0000
	Filename: R557D3GI.F1 
	BIOS Bootup Message: GV-R557D3-1GI/F1                               
                         
      
PCI ID: 1002:675f
Connector at index 0
	Type [@offset 44278]: HDMI-A (11)
	Encoder [@offset 44282]: INTERNAL_UNIPHY2 (0x21)
	i2cid [@offset 44352]: 0x92, OSX senseid: 0x3
Connector at index 1
	Type [@offset 44288]: DVI-D (3)
	Encoder [@offset 44292]: INTERNAL_UNIPHY (0x1e)
	i2cid [@offset 44379]: 0x95, OSX senseid: 0x6
Connector at index 2
	Type [@offset 44298]: VGA (1)
	Encoder [@offset 44302]: INTERNAL_KLDSCP_DAC1 (0x15)
	i2cid [@offset 44406]: 0x90, OSX senseid: 0x1

Comment 1 by Piotr Kasperczyk, Apr 17, 2012

from atiwinflash bios dump I know that it has GPU Turks

Comment 2 by Cosmosis Jones, May 4, 2012

{ 0x675F,       0x00000000, CHIP_FAMILY_TURKS,          "AMD 
Radeon HD 5570 Series",                    kNull           },

you'll, have to specify a frame buffer.

from what i've read it's baboon or eulmer, which means it's not 
turks.. so if this doesn't work..

Comment 3 by Cosmosis Jones, May 4, 2012

Status: Fixed

Comment 4 by Piotr Kasperczyk, May 4, 2012

it's surely turks, I've checked it by GPU-Z

Comment 5 by Cosmosis Jones, May 5, 2012

thats nice. as you can see from the 5/4 comment i've already added 
it and set it as TURKS.

this is in the trunk.

Created: 7 years 2 months ago by Piotr Kasperczyk

Updated: 7 years 1 month ago

Status: Fixed

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect