Chameleon

Issue 306: my 7970 cause a boot error

Reported by angel crane, Nov 28, 2012

http://www.youtube.com/watch?v=tUhTESbCSvk so when i put my 7970 in 
the card slot and try and boot up i get the weird message but when i 
turn on intel built in graphics as seen in the video i can bypass 
this message and boot fine with pcirootuid=0 then it boots up my 
7970 please add a way so i can use my 7970 without tricking your 
bootloader i have tried every bootloader out there to fix the issue 
with no luck

Comment 1 by Cosmosis Jones, Nov 28, 2012

#1, this is not a valid report.
#2, to make this a valid report you must specify everything.
dev id Vendor id, sub id.
#3 what are you kernel arguments
#4 what are you org.chameleon.boot.plist flags
#5. where is your bdmesg post
#6. What version of chameleon.
Status: AwaitingInformation

Comment 2 by angel crane, Nov 28, 2012

i do not use any flags for boot up and i do not make it to the 
kernel boot up plus my plist is what ever was installed and the 
version is the lastest and explain what is bdmesg cause i have no 
clue.and vendor id or sub id how bought we pretend that i know what 
is but don't and you explain it to me cause this error happens on 
all let me say that again all 7970's

Comment 3 by angel crane, Nov 29, 2012

my issue is 100% vaild and many more are having issues so all the 
info is in the picture figure it out

Comment 4 by angel crane, Nov 29, 2012

my bsmesg was nothing cause there was none could not get past 
bootloader loading

Comment 5 by Pablo C, Nov 29, 2012

Hello, I'm having the same issues, is this what you need?

PCI\VEN_1002&DEV_6798&SUBSYS_0B001002&REV_00
(This is for an AMD HD 7970)

Thank You!!!

Comment 6 by Cosmosis Jones, Nov 29, 2012

What is the bios size for those cards. It would appear memory is 
getting corrupted. i'd assume it's the size of the buffer is too 
small for teh bios.

what is the bios size? can you dump it w/ gpu-z in windows and 
attach?

thanks

Comment 7 by Pablo C, Nov 29, 2012

Here you have. If you need anything else I am here

Thanks again

Comment 8 by ErmaC , Nov 29, 2012

@Paolo C

I add the Southen Island support in my brach long time ago.

Pls try and report this include your DevId+SubDevID
I set the FB to Bulrushes.

But as Ap*le will start support it from 10.8.3 I never been able to 
test it.

Also install the KernelPatcher.dylib module into /Extra/modules

Have fan

Fabio

Comment 9 by Pablo C, Nov 29, 2012

I've tried using your loader and I get a white screen after the 
Apple logo.
If I unplug and plug the display connector then, I can see the mouse 
(and it's small so the res is OK).

I might have done something wrong, what did you mean when you said 
that I had to include my DevID+SubDevID (I thought you wanted me to 
post it here but I'm not sure)

Thank you Fabio

Comment 10 by Pablo C, Nov 29, 2012

Fabio, if I use your bootloader from a USB drive I have the problem 
I mentioned above. 
If I install it into the HDD I have the same problem angel crane has 
(as if I use the last stable version), I get that random string of 
characters.

Comment 11 by sea man, Dec 2, 2012

Hi , i have the same issue

I;m trying boot whit GE=Yes and GE=No but it stop at boot0 screen 
whit the same waird characters.

here is the complete data of my HD 7970 :

Device Id:1002 6798 	
Subsystem Id:1462 2770
Memory Size:3072 MB
And my bios is attached.


If you need more data just tell me !

Thanks !

Comment 12 by angel crane, Dec 2, 2012

this is my info and rom

Comment 13 by angel crane, Dec 3, 2012

Framebuffer @0xD0000000 MMIO @0xFBCC0000	I/O Port @0x0000C000 ROM 
Addr @0xFBCA0000
ATI card POSTed, reading VBIOS from legacy space
Framebuffer set to device's default: Duckweed
Nr of ports set to framebuffer's default: 4
ATI Tahiti AMD Radeon HD 7970 Series 3072 (Duckweed) [1002:6738] 
(subsys [174b:174b]):: PciRoot(0x0)/Pci(0x3,0x0)/Pci(0x0,0x0)
here is bdmesg post

Comment 14 by sea man, Dec 4, 2012

I finally got it working booting from USB .. whit the sleep trick at 
the white screen.

I have this info from the bdmes:

Using PCI-Root-UID value: 0
Framebuffer @0xD0000000  MMIO @0xFBE00000	
I/O Port @0x0000E000 ROM Addr @0xFBE40000
ATI card POSTed, reading VBIOS from legacy space
Framebuffer set to device's default: Tahiti
Nr of ports set to framebuffer's default: 4
ATI Tahiti AMD Radeon HD 7900 Series 3072MB (Tahiti) [1002:6798] 
(subsys [1462:2770]):: PciRoot(0x0)/Pci(0x2,0x0)/Pci(0x0,0x0)


Boot arguments:
-v GrapicsEnabler=No DSDT=No 

Kernel Flags:
npci0x3000


Chameleon Ver:
Chameleon-2.1-r2109 whit the 7970 id added , and booted from USB , 
because , from HD stops at boot0 screen 
whit the same fancy characters.

Comment 15 by angel crane, Dec 5, 2012

here this dsdt can work for this card Device (PEGP)
{
Name (_ADR, 0×00020000)
Method (_PRW, 0, NotSerialized)
{
Return (GPRW (0×09, 0×04))
}
Method (_PRT, 0, NotSerialized)
{
If (PICM)
{
Return (AR23)
}
Return (PR23)
}
Device (GFX0)
{
Name (_ADR, Zero)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0×10)
{
“AAPL,slot-name”,
Buffer (0×07)
{
“Slot-1″
},
“device-id”,
Buffer (0×04)
{
0×98, 0×67, 0×00, 0×00
},
“@0,name”,
Buffer (0x0D)
{
“ATY,aji”
},
“@1,name”,
Buffer (0x0D)
{
“ATY,aji”
},
“@2,name”,
Buffer (0x0D)
{
“ATY,aji”
},
“@3,name”,
Buffer (0x0D)
{
“ATY,aji”
},
“model”,
Buffer (0×13)
{
“AMD Radeon HD 7970″
},
“hda-gfx”,
Buffer (0x0A)
{
“onboard-1″
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
Device (HDAU)
{
Name (_ADR, One)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0×02)
{
“hda-gfx”,
Buffer (0x0A)
{
“onboard-1″
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
}

Comment 16 by angel crane, Dec 5, 2012

if this will help then enjoy

Comment 17 by ErmaC , Dec 5, 2012

Here we go.

Try GraphicsEnabler = Yes
(base FB is set to Aji)
Find the best solution between:
Aji Buri Chutoro Dashimaki Ebi Gari Futomaki
Hamachi OPM Ikura IkuraS

ErmaC

Comment 18 by sea man, Dec 5, 2012

Aji have dvi + hdmi 
Futomaki only dvi

But test the new boot from HD and the same fancy characters appear , 
from USB is ok.

Comment 19 by angel crane, Dec 7, 2012

here is what makes the bootloader boot my 7970

Comment 20 by sea man, Dec 7, 2012

I tried today from a HD whit MBR partition scheme whit the 
Enoch-2137-i386.zip and it work !... seems like the guid partition 
scheme is the problem, because if i boot from guid disk partitioned 
always show the fancy characters.

Comment 21 by sea man, Dec 8, 2012

Tried today to boot from USB guid disk partitioned whit the 
Enoch-2137-i386 to discard a problem whit my ssd and again the fancy 
characters appear , anyone can confirm if is only my problem ?

Thanks !

Comment 22 by angel crane, Dec 9, 2012

we all have your issues the only time i boot without error is if i 
use champlist to update the bootloader to it's lastest

Comment 23 by sea man, Dec 9, 2012

Another issue:

If you change the theme.plist resolution ie: 1920*1080 you have :

Memory allocation Error (0xdeadbeef)

or

And a ati.c error in ramdom line...

or this :

Comment 24 by sea man, Dec 9, 2012

@angel crane 

The champlist did it !

Thanks !!

Now i can boot from my HD without a USB !!

Pd: forget my last report.. my mistake.. I'm booting whit GE=YES and 
also a DSDT whit my gpu injected.. because this i get this error.. 
after i put GE=No in my org.chameleon , it boot normally.

Comment 25 by Cosmosis Jones, Feb 1, 2013

I've added 7970's to the trunk.
On my own 7970 i can't get past the boot0: done

. 
Could you please test this in your own system?

Thanks

Comment 26 by sas lasky, Mar 19, 2013

Hi, i own a XFX 7970 and have a GA Z77-DS3H Mobo without DSDT 
(ML10.8.3). I'll be glad, if you can implement the Framebuffers into 
Chameleon, so i could hopefully BOOT without DSDT-Injection. If you 
say, this took about a half Year, so i'll going to inject via 
Rampagedevs-Tutorial.
Thanx
Sascha

PS: If i can help, please let me know.

Created: 5 years 10 months ago by angel crane

Updated: 5 years 6 months ago

Status: AwaitingInformation

Followed by: 5 persons

Labels:
Priority:Medium
Type:Defect