Chameleon

Issue 366: r2318, 2326, 2327, 2332 as available via Chameleon Wizard do not support 32bit boot mode

Reported by Herve Durand, Jan 11, 2014

Causes system resets and boot loop right after reading bootargs.

Comment 1 by Herve Durand, Jan 12, 2014

Fix introduced in r2248 is now broken. We're looking at fixing it 
again.

Comment 2 by Herve Durand, Jan 12, 2014

Basically, it's related to this: 
http://forge.voodooprojects.org/p/chameleon/issues/342/

and the file that is causing the issue is fake_efi.c

Comment 3 by ErmaC , Jan 12, 2014

Owner: bungo

Comment 4 by M S, Jan 12, 2014

i replaced fake_efi.c with older regression to version 2248 i 
believe or the version we submitted to you which i still have 
locally  for issue 342, and it boots on 32 bit arch. seems related 
to bungo's changes. maybe the removal of (EFI_UINT32*) and 
ret=getSystemID

Comment 5 by Bungo, Jan 14, 2014

Changes you're pointed (I made) are related to system uuid (SMBIOS 
DMI table type 1), system-id, IOPlatformUUID and IMHO haven't an 
influece on issue described here. Follow comment 2

Comment 6 by ErmaC , Jan 24, 2014

See solution
http://www.insanelymac.com/forum/topic/231075-chameleon-22svn-officia
l-pkg-installer-binaries/?p=1988392

Ticket Closed
Status: Invalid

Created: 5 years 6 months ago by Herve Durand

Updated: 5 years 5 months ago

Status: Invalid

Owner: Bungo

Followed by: 2 persons

Labels:
Priority:Medium
Type:Defect